Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Using Sharepoint 2010 Foundation. I have a number of custom list types I create in a feature. In the previous version, the types were visible on the quickLaunch by setting OnQuickLaunch = true inside the EventReceiver. In the new version we want to hide them. So I set OnQuickLaunch = false. However, the lists are still displayed on the QuickLaunch menu. Is there another setting I need to use to hide the custom lists from QuickLaunch programmatically?

share|improve this question
    
Please tag by feature and not by version or product. This helps to attract more attention to your question and keep it relevant. See How do I use tags for general guidelines. –  Alex Angas Aug 10 '11 at 3:54
add comment

1 Answer 1

up vote 1 down vote accepted

Make sure you do SPList.Update() after you set the OnQuickLaunch property to false.

share|improve this answer
    
Update is being called as well. Could be some other issue due to the feature having been deployed with QuickLaunch ON, and it stuck in the cache or somewhere else? –  laconicdev Aug 8 '11 at 15:58
    
When you say EventReceiver do you mean FeatureReceiver? From the UI, go into List > List Settings > Title, description and navigation...Is Quick Launch set to Yes or No? If Yes, does setting it to No and clicking Save hide the list? –  Rob D'Oria Aug 8 '11 at 16:08
    
I forgot to activate the feature...OOPS.... –  laconicdev Aug 8 '11 at 16:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.