Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm in the process of integrating an image into SharePoint 2007's user profile, after a user has uploaded an image and we store it as a custom profile property in ASP.Net membership.

I've read numerous blogs around this topic and everyone points to the use of UserProfileManager within the Microsoft.Office.Server namespace. After some digging and a question on here, it was pointed out to me that SSP needs to be enabled to gain access to the ServerContext, which I have running 100%. However, SSP by default is not aware of FBA and it took me a great portion of my day to try and get this sorted.

I now have an extended web application that runs off FBA and extended the default SSP application to be FBA enabled as well.

When browsing to localhost:[myport]/ssp/admin I am prompted for FBA credentials, and can log in without issues, but I cannot browse any of the sub-actions in the administrative website with the user, such as "Profiles and Permission". Access to localhost:22428/ssp/admin/_layouts/settings.aspx works fine, it is just the sub-actions specific to SSP configuration that I don't have access to.

An example of the URL I'm trying to access: localhost:[myport]/ssp/admin/_layouts/ProfMain.aspx

I've made 100% sure that the user I'm logging in with has been set up as the Site Collection Administrator for /ssp/admin and not the the root "/" and I've reset IIS, recycled app-pools and even restarted the server in the hopes that it will fix the permissions but nothing resolved the error.

Any insight as to way this might occur would be greatly appreciated.

Note: I'm not allowed to post more than 2 hyperlinks :(

Thanks,

Eric

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Update the web.config for the default zone so that it can resolve FBA users. You can then access with your windows credentials and assign proper permissions to your FBA account. Verify that each area has permissions for this account (Search, Profiles, etc).

I have not investigated why this occurs but I've run into it before, where I had to specify user access in those separate areas of the SSP (adding a web level rule, didn't work).

Now attempt to log on with FBA. If it works you can remove the FBA entries from the web.config for your default zone (or leave it).

share|improve this answer
    
Thanks for the response. After discussing the issue with a collegue, it came to light that I had to pass permissions to my FBA users, similar to what you've recommended. I've added the membership and role provider to the NTLM enabled SSP site, and gave Personalization permissions to my FBA administrator. –  JadedEric Aug 8 '11 at 19:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.