Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I facing a weird issue. I am able to upload a 32 mb file to a Document Library. But I am unable to attach same file to a task. Do I need to change settings other than Central Admin?

I have set limit to 50MB in Central Admin.

share|improve this question
add comment

3 Answers 3

up vote 7 down vote accepted

It's not weird, it's by design. Attachments limit size is (if I remember correctly) also limited by the <httpRuntime maxRequestLength="size"/> element in web.config. Check that.

share|improve this answer
1  
Excellent! Thanks! –  saumilm Aug 5 '11 at 11:47
add comment

Just a side note. <httpRuntime maxRequestLength="" /> does not work for IIS 7. It has a new setting under system.webServer. See this blog for a reference: http://weblogs.asp.net/jeffwids/archive/2009/09/24/from-iis6-maxrequestlength-to-iis7-maxallowedcontentlengthfile-specifying-maximum-file-upload-size.aspx

share|improve this answer
add comment

Also make sure that attachments are enabled on the Tasks list.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.