Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've got some existing lists that have custom content types inherited from the Document content type. I've activated the Document ID Service feature, and any new lists I create using the same content type are working just fine.

But it's the items in existing lists that won't take the Document ID. Other things I've tried:

  • Running the Document ID Assignment job

  • Ran Gary Lapointe's propagate Content Type command:

http://blog.falchionconsulting.com/index.php/2008/05/propagate-content-type-changes/

which after adding some debugging I'm seeing that when searching for the Content Type in use:

IList<SPContentTypeUsage> ctUsageList = SPContentTypeUsage.GetUsages(sourceCT);

I'm getting a count of 0, although every item in the list is set to that Content Type.

Anyone seen anything like this or run into similar issues?

-Sean

share|improve this question
add comment

4 Answers

Remember the Limitations

ONLY content types that are derived from the Document Content Type will have unique ID’s enabled, no list items will get id’s assigned :evil:

share|improve this answer
    
by default when you enable document id it automatically adds document id to existing items in the document library. –  russell crow Jun 5 '12 at 17:53
    
add comment

It seems to take a long time for existing documents to get Document IDs after you enable them, even allowing for the daily nature of the timer jobs.

I have also found that if I run both the Document Enable/Disable and Document ID Assignment jobs for all the web applications that it seems to create the Document IDs on existing documents. I can't remember which category I did first, probably Enable/Disable. This is just from experience, and could have been entirely coincidental. But it might be worth trying.

share|improve this answer
add comment

I ran into a similar problem and found activating/deactivating the feature in Site Administration worked for me: Site Actions > Site Settings > Site Collection Administration > Site collection Features > Document ID Service

share|improve this answer
add comment

I didn't find the root cause, but I found a quick fix.

  1. Create a new content type from the “Document” type.
  2. Add the columns from the original Content Type to the new one
  3. Add the new content type to the list
  4. Remove the old content type

As soon as you upload a document using the new content type you will get a doc ID.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.