SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

According to this thread. SharePoint 2010 does not "support" using the datasheet view with multiple content types configured anymore.

But maybe somebody knows a workaround for my problem:

I have a list with two content types: one custom (called audit) and one folder content type.

When I edit list items in the datashaeet view it nicely displays all the audit columns and I can edit them. When I try to add records I can fill in all the fields and save it. When I then try to edit or view the item from a normal AllItems.aspx, I just get a single title field containing the list item id of the folder item created.

Is there a way to tell SharePoint, that it should set this default content type to "Audit"?

I've allready tried adding a (Nintex) workflow to the newly created folder and setting the content type to audit, but it doesnt change anything.

share|improve this question
    
Is Audit the default content type for the list? – Eric Alexander Aug 2 '11 at 14:30
    
yes, audit is the default content type.. – AyKarsi Aug 2 '11 at 14:58
    
Have you checked the ordering of the content type on the list? – Asad Refai Apr 28 '15 at 14:51

Try to set correct ContentTypeId at the ItemAdding event reciever.

Also please note that You should set content type id from the list schema.

share|improve this answer

Default content type is set under List Settings, beneath the Content Types section, with "Change new button order and default content type. Default will be the content type at position 1.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.