Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have workflow configured to start when an item is created. Using the datasheet view, when adding a row, the workflows are not fired.

Is this by design?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

No, definitely not by design. Generically speaking, workflows should run when adding a new item in the datasheet view.

Without knowing the specifics of what workflow method (OOB, SPD, WF, 3rd party, etc.) it's hard to give you a definitive answer.

If you add an item from a non-datasheet view does the workflow kick-off?

share|improve this answer
    
I'm using nintex workflows, and yes when I create a item normaly, (newItem.aspx) the worklows kick off fine. –  AyKarsi Aug 2 '11 at 14:00
    
You may want to contact Nintex support and see if there are any known issues here. I wouldn't expect they are doing anything that would see a item added via the datasheet any differently than an item added via a normal view, but you should verify that with them. –  Rob D'Oria Aug 2 '11 at 14:03
    
my problem seems to lie somewhere else, see this thread sharepoint.stackexchange.com/questions/17184/… –  AyKarsi Aug 2 '11 at 14:14

a workflow can also trigger in datasheet. Just make sure that fields-requiring-value are not empty.

regards, nlhizon

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.