Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a custom SharePoint solution that I am attempting to deploy to a very simple standalone SharePoint server installation. The installation has only two web applications, one for Central Admin and one for content. I've gone through the process of adding the solution to the farm using the stsadm -o addsolution command and it appears in the farm solutions list just fine. However when I deploy the solution to the content web application it does not appear in the site collection features in any site collection in that web application. What's weird is that if I deploy it to the Central Admin site collection it does appear in the features and I can use the webparts without any problems.

It seems like something got crossed up in that content web application and I can't figure out how to flush out all evidence of the solution and get it to recognize that its been deployed there. I have tried a variety of stsadm commands to retract, delete, deploy, sync and force deploy the solution to that web application a number of times with no luck. Is there another way to flush it out of there so that when it deploys it actually recognizes it or am I stuck with having to delete my web application and rebuild it?

share|improve this question
    
Could you have set the scope of your feature at the SPWeb level instead of the SPSite level? –  Laurie Jul 31 '11 at 4:30
    
I thought that may be the case but it does appear in the Central Admin web app just fine; it's only the content web app that doesn't show it. I'll double check and recompile to be sure. –  Infotekka Jul 31 '11 at 21:27
add comment

1 Answer

up vote 3 down vote accepted

Run the stsadm -o enumsolutions command from a command line on the SP server to see where and if this solution was deployed.

Thanks. I have had this happen before as well. I ran the following stsadm commands in this order. My goal was to go step by step and remove any aspect of the solution and then slowly place it back into the farm and activate it.

First deactivate the feature. Use the Name of the feature and not the .wsp name.

stsadm -o deactivatefeature -name "FeatureName" -url http://mywebapp.com

Retract the solution from the farm

stsadm -o retractsolution -name solution.wsp -allcontenturls -immediate

Run the execute server jobs command

stsadm -o execadmsvcjobs

Delete the solution from the solution store

stsadm -o deletesolution -name solution.wsp

This should give us a clean start. Now we can put the solution back.

stsadm -o addsolution -filename solution.wsp

Deploy the solution. Use the -allowgacdeployment switch if the solution needs to go to the GAC (Global Assembly Cache). Otherwise, leave it out.

stsadm -o deploysolution -name solution.wsp -url http://mywebapp.com/ -immediate -allowgacdeployment

Run the execute server jobs command

stsadm -o execadmsvcjobs

Install the feature to the farm

stsadm -o installfeature -name "FeatureName" -force

Activate the Feature

stsadm -o  activatefeature -name "FeatureName" -url http://mywebapp.com

Let me know if you have questions about these steps.

share|improve this answer
    
<Solution Name="mysolution.wsp"> <Id>56f69c73-db84-4503-b8f8-a993d52cf11a</Id> <File>mysolution.wsp</File> <Deployed>TRUE</Deployed> <WebApplicationSpecific>TRUE</WebApplicationSpecific> <ContainsGlobalAssembly>TRUE</ContainsGlobalAssembly> <ContainsCodeAccessSecurityPolicy>FALSE</ContainsCodeAccessSecurityPolicy> <Deployment WebApplication="http://mywebapp/" /> <LastOperationResult>DeploymentSucceeded</LastOperationResult> <LastOperationTime>7/30/2011 9:00 PM</LastOperationTime> </Solution> –  Infotekka Jul 31 '11 at 21:28
    
I've changed the names of the solution and host to protect the innocent, but basically it shows that it has deployed. Also I should clarify that as it is now it is not deployed to the central admin app - I had since retracted it from there because I don't want it in central admin; so http://mywebapp/ is my content web app. –  Infotekka Jul 31 '11 at 21:29
    
@Rich thanks for all of that. I had managed to do most of this in my own hapless debugging but I hadn't tried any of the feature related stsadm commands. After running through your process above I have definitely made it further along but still not perfect. The feature is active now, and the webparts work, but it still does not show up in the site collection features list at all. At this point I'm prepared to call that "good enough" since I at least am able to utilize the functionality of the solution but I'm still left scratching my head as to how I manged to hide the feature. –  Infotekka Aug 1 '11 at 0:34
    
Interesting side note: I was digging though the properties on the feature and there is an option to make the feature hidden, effectively doing exactly what I described up here. It's set to false in my feature but I wonder if it has something to do with what is causing the problem. –  Infotekka Aug 1 '11 at 3:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.