Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Have an site that is a mix of Anon and Restricted content (requires authentication). We have a picture library that is used by high level authenticated users to upload to display "advertisements" on both authenticated and unauthenticated pages (a graphic is choosen at random for display - any graphic in the library is a candidate for both authenticated and unauthenticated views).

We are using blob caching.

Currently the Picture Library is configured with ReadListItems for the AnonymousPermMask64 (among a few other permissions), but the AllowEveryoneViewItems permissions is set to False.

  1. What is the difference between setting AllowEveryoneViewItems to True and having the AnonymousPermMask64 set to "ReadListItems"? Wouldn't these, effectively, do the same thing?

  2. Should this picture library have the AllowEveryoneViewItems set to True given the scenario described?

share|improve this question
    
Should be noted...the root of this question has to do with us getting occasional "red x" (i.e. browser cannot display image). Sometimes it works great. Other times we get the red x. We see no pattern for this. One thing we do know is that the images are .png and when we remove .png from the Blob Cache list of extensions, we never see the issue. –  Brian Jul 29 '11 at 15:08
add comment

1 Answer 1

Usually, when I hear "problems, errors and no pattern", the first things I check is the blob-cache and output cache.

my actions would be:

Turn of blob-cache, just to find out if the problem still occurs. It might happen that when you visit the site with a authenticated user, your image will be cached on one of your front-ends. Then an anonymous user will visit your site and gets the image out of the blobcache: no red "x". When the blob cache is turned off, all requests are directly on the list and image, so you can check if it's a caching issue or not. If all requests for anonymous users are denied, its the list permission problem.

It might be a permission issue on your blob cache folder, too.

share|improve this answer
1  
I should have clarified my OP and follow up comment. For an answer to get marked as accepted here, I'll need a description of the AllowEveryoneViewItems and AnonymousPermMask64. This way the information is useful to others who just read the titel/OP. I will upvote anything that leads me to resolving my root issue (noted in comment of OP). –  Brian Aug 1 '11 at 16:23
    
I think the answer is useful, so +1. It certainly sounds like a caching issue. I think you ended up asking two questions here. –  SPDoctor Aug 6 '11 at 11:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.