Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a custom content type at the root of my Site Collection and set this content type to use a Word document template, which resides in a different document library on the root site. (The content type inherits from Document).

I then created a new document library and set this library to use my custom content type, as described here. The content type is associated with the new document library, and Word opens the template on my local machine when choosing "New Document"->"Content type name" from the Ribbon menu. However, after making changes to the template and clicking Save, I only get an option to save the file locally - Microsoft Word does not upload the file to the document library, which is what I was expecting. Does anyone know what is wrong?

I am using Microsoft Office Plus Professional 2010, if this makes any difference. Additionally, if I choose "File" -> "Save & Send" -> Save to SharePoint and choose the correct library from "Recent Locations", I get the error message "Could not open (url)".

[December edit: Still haven't found the solution to this issue, although I have seen it in more contexts. It currently occurs when working against an SP server accessed through the Internet, although Word <-> SP integration works fine when just editing a document in a document library. On other SharePoint farms, for example a farm in my domain, everything works as expected.

A few other people also have this problem, and AFAIK no solution exists: Link 1, Link 2. Note that the Desktop Experience Solution did not work, although when Desktop Experience was installed, it did become possible to save a document by entering the specific URL in Word. This was not possible before. The problem might also be related to Trust issues, but note that I have added the offending sites to the trusted zone and turned off Protected View in Office, to no avail.]

[Final edit: It looks like we have a solution. I previously attempted the two answers that were suggested separately. After activating both Desktop Experience on the server and installing the Web Folders update on the client, Office and SP interacts the way they're supposed to. Trusted Sites and Protected View in Office might also be part of the solution. Since it's not possible to split the bounty, I'll just toss a coin. Thanks to everyone for the input ;)]

share|improve this question
    
I have Desktop feature enabled in my windows server 2008 machine, but for some reason it doesn’t work only for cusom document library defintion instances. For default libarary – Shared Document it is working perfectly. Thanks, Shreecanth –  user4890 Sep 20 '11 at 12:11
    
Hey peter it doesn't work for me, as i am windows server 2008 version. Thanks, Shreecanth –  user4890 Sep 20 '11 at 17:17
    
@shreecant please refer from doing random comments as answers! –  Anders Rask Sep 20 '11 at 18:17
    
Is this an anonymous access web application where anon users are trying to add Word documents to document libraries? If that is the case, that (save locally) should be the only option as anon users cannot add documents to document libraries. –  PirateEric Dec 1 '11 at 15:46
    
No, access is through NTLM/AD authentication. As I said in the edit, the Word <-> SP connection works as expected when clicking on an existing document and selecting "Edit". –  Geir Smestad Dec 1 '11 at 17:29
add comment

4 Answers

up vote 5 down vote accepted
+50

After some researching I found this blog addressing "Could not open (url)":

http://petervdberg.blogspot.com/2011/01/how-to-enable-save-and-send-option-in.html

If you are using Windows 2008R2 this could be solution. I checked my machine and 'Desktop Experience' feature was already installed so I was unable to reproduce your problem.

share|improve this answer
    
Can it really be the case that this is a feature, not a bug? I have access to a SharePoint 2007 site in a different environment which lets me create a document using the "New" -> "Template name" menu and actually save the template directly to the library. If Microsoft forgot about this, it seems like a gargantuous oversight. It pretty much kills usability. –  Geir Smestad Jul 28 '11 at 14:00
    
This is not what my testing shows. OOTB SharePoint Enterprise Server 2010 using the Shared Documents on a brand new site. (Basically no customization or configuration) I can select New Document from the Dropdown in the ribbon. Edit the document and then when I go to save it, the dialog defaults to the SP Shared Documents location. It does work in an OOTB scenario. The question is why for me and not for Geir. –  Rich Ross Jul 28 '11 at 17:22
    
Could be local Word and/or OS settings. I would love to know how to setup computer to act like Geir described. –  Vedran Rasol Jul 28 '11 at 19:17
    
Since it works for me, I would be interested in collaborating on why it does not work for you and Geir. Maybe take the discussion offline, review our settings and post the answer here if there is one. Email address is in my profile for anyone interested in this. –  Rich Ross Jul 29 '11 at 0:37
    
Definitely an Office or OS issue. The functionality works the way I expect it to when accessing the site from a different computer. However, the Office version appears to be identical to the machine where it doesn't work. I really don't know where to begin troubleshooting this. If it's relevant, the non-functioning Office machine is the server that runs SharePoint itself. Can't find your email, Rich, but mine is geir.smestad@gmail.com and you are all feel free to contact me if you want to look at this. –  Geir Smestad Jul 29 '11 at 9:25
show 2 more comments

The following fix should resolve the issue:

http://www.microsoft.com/downloads/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en

What platform are you running on?

share|improve this answer
    
Hi @Pieter-Veenstra and welcome to our site. While linking in answers is accepted, please refrain from just posting links as answers. Instead explain whatever is on the page that you link to, and in the end link to the page. Remember that links also tend to have a short lifetime, so it might not work tomorrow. Please update this answer –  Anders Rask Jul 28 '11 at 13:38
add comment

I had this problem on my Windows 7 machine. On my WindowsXP machine, everything is Ok. Sharepoint version is 2007.

I fixed the problem by starting WebClient service on my PC.

Hope this helps.

share|improve this answer
add comment

I had the same issue on my SP 2010 VM. I fixed this by starting WebClient and few other services from central admin and then restarting the machine. Then it started saving the documents to document library.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.