Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm in a middle of a process of setting sp_accounts to sp services and for some wrong behaviour I'm always getting access denied when enter the webapp for all accounts.

Claims service could be the reason? Any suggestion to figure this out?

SPRegards!!!


update: mysites webapp is working just fine and got the same identity pool and sql permissions


update: Im getting the following event error when I restart the Forefront Identity Manager Service

The Forefront Identity Manager Service cannot connect to the SQL Database Server. 
The SQL Server could not be contacted. The connection failure may be due to a network failure, firewall configuration error, or other connection issue. Additionally, the SQL Server connection information could be configured incorrectly. 
Verify that the SQL Server is reachable from the Forefront Identity Manager Service computer. Ensure that SQL Server is running, that the network connection is active, and that the firewall is configured properly. Last, verify the connection information has been configured properly. This configuration is stored in the Windows Registry.

SOLUTION: for some reason I re-run the following script and started to work, but the FIM Service issue keeps annoying (waiting to required time to set an answer)

share|improve this question
add comment

3 Answers

Have you checked the application pool identity has the correct permissions on the SQL Server database?

share|improve this answer
    
yes, the identity account of that app pool is db owner in all SP databases. it could be possible that is missing some other permission... –  fallout Jul 22 '11 at 12:34
add comment

Ahh impatient, impatient -- technet says that you have to do the CA bit and the powershell bit .. Was getting so used to techned showing you how to do it through the UI and through Powershell that I just got used to picking up the powershell and leaving the rest for what it is ;-)

'You can configure the user accounts for the object cache by using Central Administration and Windows PowerShell. You must first create the accounts in the Central Administration Web site and then add the accounts to the Web application by using Windows PowerShell. You must add the user accounts to each Web application.'

share|improve this answer
    
I am not sure this is an answer. Once you have a bit more reputation you will be able to post comments on the question or answers. –  SPDoctor Dec 2 '11 at 17:47
add comment
up vote 0 down vote accepted

run this script and set super user permissions to the sp farm account.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.