Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm stumped. Profile pictures are appearing correctly everywhere in SharePoint except People Search results. Here's how I tested:

  1. I did a full AD import.
  2. I edited my profile, including the PictureURL property (display name: Picture) as well as a couple other properties.
  3. I ran a full crawl of the MySites host.
  4. I performed a People Search for my last name. -- Verified that all of the edited properties appear correctly, except the PictureURL.

I verified that the XSL wasn't the problem by using the following nifty XSL trick to display the raw search result XML:

<?xml version="1.0" encoding="UTF-8"?>  
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">  
    <xsl:output method="xml" version="1.0" encoding="UTF-8" indent="yes"/>  
    <xsl:template match="/">  
        <xmp><xsl:copy-of select="*"/></xmp>  
    </xsl:template>  
</xsl:stylesheet> 

Turns out the "pictureurl" tag in the search results has no value.

I checked the managed property settings for PictureURL, and it's using the out-of-the-box values:

ows_PictureURL(text)
People:PictureURL(text)

What could be going on? Do I have to reset the managed property somehow? I've never delved deeply into SharePoint search, so I'm hesitant to start poking around with the managed properties without direction.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I figured it out: for some reason, I had unchecked the checkbox for "Indexed" on the Edit Profile Properties page for PictureURL (on the SSP Admin site). I'm leaving this silly question here in case somebody else has as hard a time googling this as I had.

share|improve this answer
    
setting indexed would help ;-) –  Anders Rask Feb 26 '10 at 8:33
    
"Uncheck" the checkbox for "Indexed" worked for me. Thanks! –  user16929 May 10 '13 at 17:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.