Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have SharePoint 2010 Foundation installed on win server 2008 r2 and I have created a web application with classic authentication and another web application with claim based authentication. SharePoint foundation search service is up and running.

Search works fine in the web app with classic authentication but its failing in claim based authentication application. Except the authentication mode every other settings are same in both the application.

Event viewer shows this entry for the claim based web app:

The start address sts4://server:2220/contentdbid={05851f7d-bce5-4ae9-83d6-e19062ffec20} cannot be crawled.

Context: Application 'Search_index_file_on_the_search_server', Catalog 'Search'

Details: Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled.

What could be the possible reason ?

share|improve this question
    
A well written question encourages people to answer it. Please read our guidelines which I've used to improve your post (i.e. tagging, title, removed salutations). You can also read How to Ask for more general guidelines. –  Alex Angas Jul 20 '11 at 23:28
    
ok thanks, will follow those guidelines in future –  JeeZ Jul 21 '11 at 5:25

1 Answer 1

up vote 2 down vote accepted

This appears to be a permission issue.

MS has post-configuration steps for Search, you can go thru this and check your settings http://technet.microsoft.com/en-us/library/ee808863.aspx

Be sure your farm and web app search configuration are not conflicting.

Search can be picky, the best configuration IMHO for your WebApps are to have the defaults zone enabled with classic or claims with NTLM provider on port 80. Keeping things this way (or changing them to match that) has solved a great deal of the Search issues I've encountered with SharePoint.

share|improve this answer
    
Thanks for the info. I had been through that page but none of the steps was of help ! :( –  JeeZ Jul 20 '11 at 7:58
    
Search needs Windows Auth to do the crawl, so ensure the NTLM provider is enabled for the zone search is using. Additionally, verify your crawl account has full read access to the all content in the webapp for the zone with Windows Auth enabled. –  Jesus Shelby Jul 20 '11 at 12:44
    
Thanks Jesus, it worked ... after reading your comment I cross checked and found that, the search zone associated with application was not configured with NTLM! –  JeeZ Jul 21 '11 at 5:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.