Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've download (KB 2460045) and install the sp1 for SPS2010, so far so good. To complete the process -SQL upgrade- I must run the SP2010 Products Configuration Wizard (psconfig), but in the last step a error occurred:

Failed to upgrade SharePoint Products.
        An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown.  Additional exception information: Failed to upgrade SharePoint Products.
        Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException: Exception of type 'Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException' was thrown.
           at Microsoft.SharePoint.PostSetupConfiguration.UpgradeTask.Run()
           at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

Configuration of SharePoint Products failed.
Configuration must be performed in order for this product to operate properly.
To diagnose the problem, review the extended error information located at -logfilePath-, fix the problem, and run this configuration wizard again.

ideas?

environment: WSDatacenter 2008 SP2 with SPS2010 (SPF2010 not installed) || using the same account that the timer and all content databases are readonly = NO


psconfig log:

INF                  SyncUpgradeTimerJob: Upgrade timer job failed. Return -1.
ERR                  The exclusive inplace upgrader timer job failed.

ULS Log:

UpdatedConcurrencyException: The object SPWebApplication Name=SharePoint was updated by another user. Determine if these changes will conflict, resolve any differences, and reapply the second change. 
This error may also indicate a programming error caused by obtaining two copies of the same object in a single thread. Previous update information: User: -adminAccount- Process:OWSTIMER (5928) Machine:-serverName- Time:July 13, 2011 02:18:36.0000 Current update information: User: -adminAccount- Process:OWSTIMER (5928) Machine:-serverName- Time:July 13, 2011 02:18:36.8

upgrade Log:

[OWSTIMER] [SPUpgradeSession] [ERROR] [7/14/2011 10:49:42 AM]: Upgrade [SPContentDatabase Name=WSS_Content] failed.
[OWSTIMER] [SPUpgradeSession] [ERROR] [7/14/2011 10:49:42 AM]: Exception: Object reference not set to an instance of an object.
[OWSTIMER] [SPUpgradeSession] [ERROR] [7/14/2011 10:49:42 AM]:    at Microsoft.SharePoint.ApplicationRuntime.SafeControls.GetTypeFromGuid(Guid guid, Guid solutionId, String assemblyFullName, String typeFullName, Boolean throwIfNotFound)
   at Microsoft.SharePoint.Upgrade.SPContentDatabaseIntegrity.CheckWebParts()
   at Microsoft.SharePoint.Upgrade.SPContentDatabaseIntegrity.Check(Boolean calledFromHealthRule)
   at Microsoft.SharePoint.Upgrade.SPContentDatabaseSequence.ContentDatabaseDataIntegrityCheck()
   at Microsoft.SharePoint.Upgrade.SPContentDatabaseSequence.PreUpgrade()
   at Microsoft.SharePoint.Upgrade.SPUpgradeSession.Upgrade(Object o, Boolean bRecurse)

in SP Management shell im getting False to the follow command: (get-spserver $env:computername).NeedsUpgrade

what doesn't make any sense cause in CA the DB have the following status: Database is in compatibility range and upgrade is recommended and the schema version error event is constantly trigger out

share|improve this question

11 Answers 11

up vote 3 down vote accepted

That error can be caused by a lot of things, e.g.:

  • service accounts with invalid passwords
  • missing feature dependencies
  • missing content databases
  • lack of permissions of your account
  • the user account control (UAC) on the server (eventhough you should see a "access denied" error)
  • a previous unfinished upgrade process
  • any many more...

I recommend rebooting the machine (I guess it is a test farm).
Use an account that has all permissions on SharePoint and SQL server (Again, we are talking about non-productive farms)
If that does not help, you might want to disconnect all content databases and update only the system db's (like Configuration and Service Application databases) -if that works, you know that there have to be someting in your content databases. Attach them 1 by 1 to check which causes the problem.

share|improve this answer
    
for some reason there was a db that doesn't appears in the 'Manage Databases Upgrade Status' that contains some errors (using Test-SPContentDatabase found some SiteOrphans) and was preventing the psconfig upgrade from moving on. After detach and attach, those errors keep making the upgrade fail, so the only way is run it with that db detach. Bas Lijten and AlexPoint, thank you guys! –  fallout Jul 20 '11 at 10:22

I had the same errors. Detaching databases didn't help, it was for some reason, the langue packs that were bugging me. After deinstalling the language packs, and running PSconfig again, my upgrade finished!

correct upgrade order (In my opinion ;). some people think different about the subject):

  • install SP1 - foundation
  • install SP1 - Server
  • psconfig
  • install language packs
  • install language pack SP1 foundation
  • install language pack SP1 server
  • psconfig
  • install CU june r2 foundation
  • install CU june r2 server
  • psconfig

and please follow the guidance about detaching content databases on technet. It really speeds up your process ;)

share|improve this answer
    
gonna try it, thanks. –  fallout Jul 13 '11 at 16:35
    
Thanks anyway Bas, but after install de lang pack [microsoft.com/download/en/confirmation.aspx?id=3411] I run the psconfig and it still fail. I'm pulling my hair off with this...there's tons of posts based on this issue but any solution tip works. really starting to love MS SP releases... –  fallout Jul 13 '11 at 17:26
    
you weren't reading correctly I think: de-install all language packs and then run psconfig.. –  Bas Lijten Jul 13 '11 at 17:36
    
my mistake. but I've de-install it, run the psconfig and get the same 9 step error. –  fallout Jul 14 '11 at 8:48
    
still having problems? Did you try to run psconfig with a -force parameter from the commandline? A last hope can be to roll out CU June v2. But this is not a recommendation!!! Only do this if you really don't see ANY other options anymore. –  Bas Lijten Jul 15 '11 at 14:56

you can use command "net start sptimerv4" in command window when the wizard is starting phase 9/10, then you can see it's work fine!

share|improve this answer
    
I tried many other approaches, but this one was only working way. –  Sanghoon 14 hours ago

I had the same problem. It turns out I just needed to remember to run the SP2010 Products Configuration Wizard by right clicking and using "Run As Administrator". (as my system is deployed on a Windows 2008 R2 server).

Even though I was logged in with privileged accounts (including the admin account used to install SharePoint in the first place), it would fail at the end unless I ran the wizard As Administrator.

Once I re-ran it as administrator, it all worked.

share|improve this answer

Have you tried running PSConfig again? I have seen this error as well and running it a 2nd time completed successfully.

share|improve this answer
    
yes..I retry it in any possible ways, but always with no success. –  fallout Jul 13 '11 at 14:36

I had the same issue, the solution to solve it is very simple.Just make sure you start Microsoft SharePoint Foundation Web Application on the server which will run the configuration wizard before starting.

Best regards

share|improve this answer

For me, I had to make a database backup and uninstall SharePoint and all extras like Office Web Apps and language packs and then reinstall

share|improve this answer
    
drastic solution :) –  fallout Jun 21 '12 at 11:19
    
Yep, it was, but I didn't find any other way... and it was in a testing environment –  lex Jul 12 '12 at 10:54
    
important is working! –  fallout Jul 12 '12 at 12:49
  1. Try to manually start the SharePoint 2010 Timer service.

    For some reason after upgrading from WSS 3.0 SP2 > WSS 3.0 SP3 > SPF 2010 > SPF 2010 SP1, when I tried to manually start this service I received login failed error.

  2. If you do receive the login failed error, like i did, then reset the login account's password in the computer management.

  3. Again, manually start the service.

  4. If the timer service starts, then run the SP Configuration Wizard (run as administrator)

SP 2010 Timer service

share|improve this answer

I had the same message on a SharePoint 2013 farm after a recent CU. My account had correct permissions and I verified that the timers were running. Even when I tried psconfig through the command line it failed.

Here is what worked: Restarted all WFE servers. I even restarted the SQL server for kicks and giggles Cleared the configuration cache Ran psconfig.exe -cmd upgrade b2b -wait Sucess!!!

Hopes this helps

share|improve this answer

Try to run the following command where the -wait will probably solve your issue: psconfig -cmd upgrade -inplace b2b -wait -force

share|improve this answer

Running the PSConfig as the same user that is used for installing the SharePoint farm to begin with, should do the trick.

Best practice is to use a SPSetup account for all your installs, patches and updates.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.