Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I seem to be missing a '1033' directory for my SharePoint 2010 installation. Here's the full details:

We upgraded from SP2007 to SP2010 using the database attach method. Some resources have a 1033 folder in their URL (for instance, the Documents link on a site collection points to sharepoint.domain.com/_layouts/1033/viewlsts.aspx), but this does not exist on the server. I installed the English Language 1033 pack and it says it was successful and it shows as being installed on the server, but URLs still don't work. If I take out the 1033 the URL works but it's built in to so many places we need to get it working. It worked fine on the SharePoint 2007 server. The error message I get is:

The resource cannot be found. Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /_layouts/1033/viewlsts.aspx

Again, if I remove the 1033 the URL works fine. How can I make SharePoint interpret this URL correctly?

share|improve this question
add comment

6 Answers

Did you manually add that link? Looks like the only viewlsts.aspx I can find resides directly in the /_layouts/ directory. It's possible that the old viewlsts.aspx was localized and was replaced in 2010 by a generic viewlsts.aspx containing resource strings.

share|improve this answer
    
No, that's the link that is used in the Quick Launch bar. You're correct that the file only resides in _layouts. On the 2007 server the URL has the 1033 in it if you hover, but when you actually click the link the URL it takes you to does not have the 1033. It seems to know to redirect/ignore it. –  iltl32 Jul 12 '11 at 16:46
add comment

I have never known viewlsts.aspx or any other system application page to exist in or be directed to the Layouts localised folders.

The only files that normally reside there are javascript and image files.

viewlsts.aspx is a server side page which contains its own tokens to get localised strings from the resource files, using standard ASP.NET techniques as the page is compiled. There is no need for a localised version of this file.

The reason you could be seeing the 404 is because a resource on that page (such as a localised javascript file) is being requested by a control and can't load it, so throws the exception which bubbles up to the page.

I would attempt a rebuild of the entire Web Front End (perform a re-install, and re-run the config wizard) and reattach to your farm.

share|improve this answer
add comment

Hi had the same issue with this. I resolved it by manual updating the top link bar as follows:

  1. Click site settings (you will have to remove the 1033 folder in your url link)
  2. Click Top Link Bar under Look and Feel
  3. Select each link and manually remove the 1033 folder and save.

Hope this is of some use

share|improve this answer
add comment

"NavNodes" tables in Database are having Global and Current navigations references which are showing reference of 1033 in their URLs, so need to delete this ‘/1033’ text from all URLs. Reference of ‘/1033’ is used only in SharePoint 2003. This is not more in use in MOSS 2007 and SP2010.

Steps to update Navigations URLs in MOSS 2007 or SP2010:

  1. Open SQL Management Studio
  2. Select newly migrated database and click on New Query.
  3. In New Query wizard at right side, copy following SQL script (shown in script) and execute it.

     UPDATE [DatabaseName].[dbo].[NavNodes]
     Set URL = '_layouts/viewlsts.aspx'
     where URl = '_layouts/1033/viewlsts.aspx'
    
     UPDATE [DatabaseName].[dbo].[NavNodes]
     Set URL = '_layouts/settings.aspx'
     where URl = '_layouts/1033/settings.aspx'
    
     UPDATE [DatabaseName].[dbo].[NavNodes]
     Set URL = '_layouts/create.aspx'
     where URl = '_layouts/1033/create.aspx'
    
     UPDATE [DatabaseName].[dbo].[NavNodes]
     Set URL = '_layouts/mtgredir.aspx'
     where URl = '_layouts/1033/mtgredir.aspx'
    

Database update step should be followed by IISRESET on all WFE servers.

Once you update the URL value you should activate ‘‘PublishingPrerequisites’ and then ‘PublishingResouces’ features for each site using STSADM utility:

Steps:

  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. Go to command prompt and locate 12 hive folder.
  3. Run following command for each migrated sites.

stsadm.exe -o activatefeature –filename “PublishingPrerequisites\feature.xml” -url -force

stsadm.exe -o activatefeature –filename “PublishingResources\feature.xml” -url -force

share|improve this answer
add comment

What about using the IIS Rewrite Module? You could have a rule that looks at any url with /_layouts/1033/ and rewrite it to /_layouts/ . That should allow you continue to use the 1033 folder within URLs without having to move or change anything within SharePoint.

share|improve this answer
add comment

There is a simple solution to this issue. It is just a question of missing Files in Dir 1033. Copy the files form /layout/ to /layout/1033 and you should be good to go

share|improve this answer
    
This is not a recommended solution, as it would have to be replicated on each web front end, this step would have to be logged for support, and again repeated each time a web front end needed to be rebuilt, and a subsequent service pack could undo the action. Too must risk involved with this solution. –  James Love Dec 12 '11 at 18:30
    
James, I tried this option just to keep things rolling on the test environment. I have the same issue in all the server (Dev, test, staging). and i have tried to re built it twice. The complete scenario is that we are upgrading from Sharepoint 2003 to SP 2010. There are many Custom feild.. is there a better way to do it???.. Thanks K –  Kunal Dec 14 '11 at 20:37
    
You are migrating via SharePoint 2007 yes? There is no direct migration path without the use of third party tools. –  James Love Dec 14 '11 at 21:06
    
yes we did it through a Virtual migration environment (Via 2007). Attach and upgrade method for the content database. –  Kunal Dec 14 '11 at 21:45
    
I would next check the masterpage then. It might be that your upgraded site is still using an SPS2003 Quick Launch Data Source Control. –  James Love Dec 14 '11 at 22:00
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.