SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting several users getting access denied for some SSRS reports that are in a reports directory in SharePoint 2010. I have a single sharepoint group with all users in it so all users have the same level of permissions (as an example I'll use testaccount and ryanhayes as account examples where testaccount is a domain account and ryanhayes is a domain account that is set up as a sharepoint administrator).

ryanhayes has full access to the reports and can run them and view the results.

testaccount has the same level access as they are both in the same group for the report library, but when trying to view a report, the user is greeted with the error:

The permissions granted to user 'MYDOMAIN\ryanhayes' are insufficient for performing this operation. (rsAccessDenied)

SSRS is set up in SharePoint integrated mode.

The permissions of the group on the reports directory is (overkill, I know, but I've been working on this for about a day now):

Full Control, Design, Contribute, Read, View Only

Again, the sharepoint admin account has the same level access (full) as everyone else in the group, but can view the report with no problem, while others get the insufficient permissions message.

What/where do permissions need to be granted to allow everyone in the group to be able to run the SSRS reports? Is this a permission setting at the SharePoint level? Central admin? SSRS or SQL? Any direction is greatly appreciated.

share|improve this question
up vote 4 down vote accepted

Adding that group to have access to the datasources used by the reports fixed the problem. It worked for my account because as SharePoint admin I had access to the library that contained the datasources.

share|improve this answer
Thank you very much. It saved me ton. – user8124 Apr 30 '12 at 18:58
Thanks Ryan - Giving access to the data connection source "library in SharePoint" solved the issue – user15157 Feb 26 '13 at 16:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.