Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We are using SharePoint 2010 Standard. We have a site collection that is setup with publishing features turned on. I need search to index and serve minor (unpublished) versions as well as published versions. I have given the content crawl account full control at the web-app level, however the documents that have never been published are still not being indexed.

Is there a way to force SharePoint to index and serve unpublished documents?

Many Thanks

share|improve this question
1  
can you log in as search crawl account and verify that it can see minor versions? –  Ashish Patel Jul 4 '11 at 17:52
    
Hi Ashish, I logged in as the crawl user and i can see the minor versions (and check them out). These minor versions still aren't being indexed. As soon as I publish a major version and do another crawl the document is searchable. –  toby Jul 5 '11 at 10:34
add comment

2 Answers

Verify that the account has permission to see these draft versions. The libraries may be set up so that only approvers and the original author can see the unapproved content. That means the crawl account needs to be in the Approvers group

Keep in mind that this will result in draft versions appearing in search results for everyone to see. Then, some users will receive an Access Denied message when trying to open these unpublished files.

share|improve this answer
    
Thanks for your suggestion Laurie, I have logged in using the crawl account and I can see the documents. Also I have checked the library settings, content approval is set to off and draft visibility is set to 'Only users who can edit items'. –  toby Jul 5 '11 at 10:36
add comment
up vote 1 down vote accepted

The effected libraries had the option Library Settings > Versioning Settings > Draft item security set to 'Only users who can edit items'.

My crawl account did have full control of the documents in the library and I logged in using the crawl account to confirm this.

When i changed the above option to 'Any user who can read items' then reset the index and did a full crawl, the documents where indexed and are now being served up by search.

I had previously read that the crawler ignores this option but it seems that it interprates it in an unexpected way.

Interestingly (and frustratingly) when i changed the 'Draft Item Security' option to 'Any user who can read items' and did an incremental crawl, the documents were not added to the index, i had to to do a full crawl for the change to be noticed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.