Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a strange problem where the MS Word documents my documemt libraries are not being indexed. When i look at the crawl log i can see that the crawl is indexing the libraries themselves but not any of the documents within them.

I have checked the following setting and it is set to Yes: Library settings > General Settings > Advanced Settings > Allow items from this document library to appear in search results?

I have also added the 'Default content access account' to the members group of the site (as I want to also index drafts). The documents not being indexed are a mixture of checked in and drafts.

It might be useful to know that the sites containing the document libararies use the Team Site template, the site collection has publishing turned on. Everything was created programatically.

I'm pulling my hair out with this so any suggestions of what i can check or how i can approach this issue would be greatly appreciated - I have only been working with SharePoint for 2 months so I'm still learning.

TIA

share|improve this question
    
Update - All of the document libraries that I create are using a custom content type that derives from Document. This is defined in a seperate site collection that is not included in the search crawl. Maybe there is something I need to do with the content type to get it included in the crawl? –  toby Jul 4 '11 at 14:25
    
I found the issue but don't have points on StackExchange to answer it. We have the publishing feature turned on and the documents where not yet published. Now I need to find out how to include these unpublished in the search index - any suggestions appreciated. –  toby Jul 4 '11 at 15:55

4 Answers 4

up vote 2 down vote accepted

I finally found the issue and it wasn't the publishing feature that was causing it.

The effected libraries had the option Library Settings > Versioning Settings > Draft item security set to 'Only users who can edit items'.

My crawl account did have full control of the documents in the library and I logged in using the crawl account to confirm this.

When i changed the above option to 'Any user who can read items' then reset the index and did a full crawl, the documents where indexed and are now being served up by search.

I had previously read that the crawler ignores this option but it seems that it interprates it in an unexpected way.

Interestingly (and frustratingly) when i changed the 'Draft Item Security' option to 'Any user who can read items' and did an incremental crawl, the documents were not added to the index, i had to to do a full crawl for the change to be noticed.

share|improve this answer

What kind of document you mean? You say checked, there are only office documents or pages? Because some types of documents cannot be searched unless SP knows how to read their format (like PDF) and you must use something that can read it (iFilter).

share|improve this answer
    
Hi Molik, they are Word 2007 documents (docx). Thanks, Toby –  toby Jul 4 '11 at 12:00
    
It was a good suggestion, because RTF documents also require certain configuration effort to crawl. –  Alexey Krasheninnikov Jul 4 '11 at 13:36
    
If they were unpublished, query removes them from search results because users can't see them (that is theory from books, I never test this functionality myself). I don't know how to add them because I'm not the programator, but some "cheat" like this support.microsoft.com/kb/923900 may help you –  Molik Jul 4 '11 at 17:37

Even i have the same issue, not all the content of document library is indexed. Only 10% out of the entire documents of the document library was indexed and appears in search.

As mentioned above i checked with versioning settings, but for this doc library, versioning is disabled. I moved the site from test server where it is working fine, restored it in to production. Made all the required things such as full crawl, created meta data properties etc and again full crawl after creating them. But since the first Full crawl not all the contents are being indexed. Kindly let me know if any have faced issue like this. Appreciate your kind help on this.

want to update that, publishing feature is not enabled in the site and the template is a team site. There fore the publishing option also ruled out.

share|improve this answer
    
Do you have item level permissions on the items in your library? If so this could be the issue, you need to ensure that the search crawl account has read access to the entire web application. You might also want to check whether the missing items are checked in. Let me know how you get on. –  toby Jan 25 '12 at 10:31

If you have all of this created programmatically, make sure that the related code is also deployed to the server where the search indexer runs. I have had a similar issue with content that was created through a feature (this included list definitions and a pre-defined folder structure). We had to deploy this feature also to the search server.

share|improve this answer
    
Thanks Marik, that is a good point and something I need to be aware of in future. However I don't think that in this case it will solve my problem as the Word documents within the libraries where added by hand after everything was built. Thanks for your comment though. –  toby Jul 4 '11 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.