Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

If I enable an RSS feed on a document library within a publishing site I get something like this Url:

Clicking any of the entries from the generated list takes me to something like this Url:

Which is rubbish, for two reasons...

  1. DispForm is an application page – completely different to my web site branding.
  2. You need to deactivate the publishing lockdown feature for anonymous users to see this page.

How do I stop this from happening?

Really I want the generated link in the XML to point to the branded Url of the content

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted

For your first issue:-

Is your site a public site? You could always use feedburner to create a more friendly url to the RSS feed. You'll probably also get better stats as to the usage of the feed too!

For your second problem:-

Under RSS settings for your pages library, have you set the options under Document Options -> Link RSS items directly to their files?

Thanks goes to Waldek Mastykarz for this insight http://blog.mastykarz.nl/inconvenient-wssv3-rss-feeds/

share|improve this answer
add comment

For the feed: What about getting the output you want through a Content Query Web Part and enabling the RSS feed for that? You would need a a dummy page to host the WP and do a bit of configuration but that might give you the flexability you need.

MSDN: Customize RSS for the Content Query Web Part

For the branding problem I assume you are using a master page? Have you set both the custom (site) master page and the system master page? The list/library forms (dispform.aspx) is controlled by the system master page. If your system MP is set to whatever you are using for your main site master page that should at least let you see your custom branding (if the CQWP option above fails)

share|improve this answer
add comment

i have a little different issue here.

i published a rss from a custom list to the internet: http://www.XYZ.com/_layouts/listfeed.aspx?List={7CFG41E9-8BCF-9A8A-A77F-6CEEE7899AEE}

but the rss item title links to: http://www.XYZ.com/Lists/ListName/DispForm.aspx?ID=123

the problem is that in the list RSS setting, there is no "Document Options" as mentioned above.

any ideas?

share|improve this answer
add comment

You can change the display form for the list in SharePoint Designer to point to any other page you'd like. Open the site, right click on the list, choose Properties, then go to the Supporting Files tab. There, be sure to select the Item Content Type (or whatever Content Type you're working with), NOT the Folder Content Type. Then browse to the form you'd like to use for display, save, etc., and you should be good to go.

share|improve this answer
    
That seems to set the default view used when viewing the list within the application page, it doesn't seem to change the link generated in the xml. –  Rob Feb 16 '10 at 16:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.