Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I try to open any file in the Sharepoint Designer I am getting the message:

Server Busy

The action cannot be completed because the other program is busy. Choose 'Switch To' to activate the busy program and correct the problem.

Clicking the 'Switch To' button just opens the Start menu. Clicking 'Retry' doesn't do anything.

I have tried rebooting the server but that doesn't help either.

Any ideas?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Typically when that message appears there is some security negotiation that is taking a while behind-the-scenes. If you are using AD security, there are a few things to check. First, you need determine if you have access to the document through the front-end (navigate to the page/document in the browser). If that works then you need to determine if you have access to use SharePoint Designer. In the top-level site of the site collection, go to the site permissions area: /_layouts/user.aspx, then under settings select "Permission Levels". There is an option in each define permission level called "Use Client Integration Features", you want to make sure that is turned on.

Further, if you are using FBA identity you will need have open SharePoint in your browser and log in to use SharePoint Designer.

share|improve this answer
    
I have all the permissions and it was all working on Friday, it was only today that there was a problem. But a couple of restarts, of both server and my machine, seems to have fixed the issue. +1 for detailed answer. –  anothershrubery Jun 27 '11 at 14:26
    
I'll mark yours as answer too, why not sure! –  anothershrubery Jun 27 '11 at 14:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.