Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

While trying to open an excel document stored in "Shared Documents" library, the excel application opens up with a login prompt, to which I passed the login credentials of the site. After which the excel shows an error

"Could not open 'http://sp2010//shared documents/Sales.xlsx'"

The same is the case for word documents too. I am running SharePoint 2010 server on windows 2008 R2. The same machine is used for development. MS Office 2010 Professional plus installed on the same machine (not activated). The browser version i am using is IE8.

After searching the net, I tried the following steps but nothing turned to solve the problem

  1. Enabled the "Desktop Experience" feature in windows server 2008

  2. Unchecked "Auto proxy detection" in IE settings.

  3. Added the site to trusted list in IE.

  4. In excel added the Sharepoint the URL 'http://sp2010/' under 'Trust Center' options.

  5. In excel unchecked all "protected view" options under 'Trust Center'.

  6. Tried applying the "127.0.0.1" as proxy, didn't work and reverted it back.

I tried opening the 'Sales.xlsx' after downloading the file from "Shared Documents", which opened up without any issues.

Now I am completely out of options on what to do next to get this working.

Please help.

Update: I had disabled the server firewall but the problem still persisted. Thereafter I mapped a network drive to the following url 'http://sp2010' to which I was able to browse the location where the 'Sales.xlsx' was located. But opening file from this location too gave me the same error.

Update: Finally it seems like I had got the culprit behind this wired behavior. I am posting the steps that worked for me. It seems the temp contents in the 'OfficeFileCache' along with SharePoint workspace was the reason behind the issue.

share|improve this question

6 Answers 6

up vote 5 down vote accepted

I noticed that SharePoint Worksapce was running in the system tray which had the "Shared Documents" library synced, because of this there were some temp files out there in the following location

"c:\Users\login_user_name\AppData\Local\Microsoft\Office\14.0\OfficeFileCache"

after terminating the Sharepoint workspace and clearing those temp files, I was able to open documents in Office client.

share|improve this answer
1  
Sharepoint workspace wasn't running for me, but deleting the contents of the that folder still fixed the problem –  OlduwanSteve Apr 15 '13 at 14:02
    
This worked for me. - thanks Abraham. –  Kannan Jun 24 '13 at 6:25
    
deleting the files in c:\Users\login_user_name\AppData\Local\Microsoft\Office\14.0\OfficeFileCache worked for me as well. –  user24177 Mar 5 at 21:01

We had to open a case with Microsoft about this same issue. We literally tried every solution suggested in this thread and many others (IE settings, Office Trust Center settings, removing cache directories, etc, etc). It turned out that a pre-release version of Office was installed on the affected machines. The pre-release version (found in Control Panel -> Programs) was 14.0.4734.1000. Microsoft support told us that the pre-release version had issues integrating with SharePoint. Uninstalling the pre-release version and installing a release version solved it for us. I hope this prevents some weary soul from investing the hours we did into a bunch of nothing!!!

Here's the link for valid release versions of Office:

http://support.microsoft.com/kb/2121559

share|improve this answer

The only thing I can think of is that when opening a file from SharePoint directly, Word uses WebDAV to communicate with the server. If this protocol is disabled in the firewall for instance, Word would be unable to retrieve the contents of the file.

share|improve this answer
    
Yeah as you said I did disable the firewall too, but still the same. I was able to sucessfully map the url to my site sp2010 as a network drive under "My Computer" and was able to browse the same, but if I try to open documents from there, then again the same problem shows up. Anyway thanks for pointing out any chances with firewall. –  AbrahamJP Jun 24 '11 at 17:55
    
Another thing: In the web app's general settings (Central admin -> web apps, select web app, general settings in the ribbon), do you have client integration enabled? –  Colin Jun 24 '11 at 17:59
    
I did verify the option you had mentioned. The 'Client Integration' is enabled for the web app. thanks for that. I believe, I am almost near to the solution after clearing the 'OfficeFileCache'. –  AbrahamJP Jun 24 '11 at 18:25

Also make sure that Word has access to the network. I sumbled across this in a VM with no network support : in this case, even in local, word won't open the document after all this.

share|improve this answer

Installing secure store service and followed by installing excel service application and connecting web application to the excel service application will solve the above problem.

In order to open all office documents from SharePoint you need to do following steps:

  1. Internet Explorer --> Tools -->Internet Options -->Advanced tab -->click Restore defaults button -->Click "OK"

  2. Internet Explorer --> Tools -->Manage Add-ons --> disable NameCtrlClass, SharePoint Opening Documents control (controls by selecting currently loaded add-ins from left pane dropdown menu) controls

  3. Close and re-open the Internet explorer and check the documents functionality

share|improve this answer

for me only executing 2 lines of power-shell from http://blogs.technet.com/b/excel_services__powerpivot_for_sharepoint_support_blog/archive/2013/05/21/excel-services-the-workbook-cannot-be-opened.aspx fixed the issue

$w = Get-SPWebApplication –Identity http://tschauer
$w.GrantAccessToProcessIdentity("Devtest\Excel_Services_Account")

it was due to migrating WSS_content_XXX to another server. for me the new server was SQL server 2012 which i used the always-on listener name instead of actual servername.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.