Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm not sure what settings we changed, but I can no longer view a Web Part Page in the SP Designer "Design" window/view. I receive the same warning statements if I create a new Web Part Page (but ASPX/HTML Pages work fine) or try to open an old Web Part Page.

When I open a web part page in SP 2010 Designer the window appears with: "You do not have permission to do this operation. Ask your web site Administrator to change your permissions and then try again, or log on with a user account that has this permission. To log on with a different account click okay."

When I click cancel the following appears in the "Design" window. Master Page Error The Master Page http://xxxxxx/_catalogs/masterpagev4.master cannot be loaded. Attach a different Master Page, or correct the problem in code view.

1) Previously, I was able to edit/create Web Part Pages without any problems. 2) I can use "Advanced Mode" and alter the code, but still receive the same Permission Error shown above and still cannot see the page in the "Design" Window. 3) When I check permissions on a Page, I am listed as "Owner" - Full Control, Limited Access. 4) Central Admin - Sharepoint Designer Settings: All 4 boxes are checked. 5) I can still create/edit workflows and edit pages outside of SP Designer.

If you have any idea of what I changed to prevent viewing/editing in the SP2010 Designer "Design" window I'd really appreciate any help.

Thank you.

share|improve this question

migrated from stackoverflow.com Jun 23 '11 at 10:29

This question came from our site for professional and enthusiast programmers.

3 Answers 3

Try to change user in SPD2010, it's an icon down at the lower left on the screen.

share|improve this answer

Check for SharePoint Designer settings @ Site Collection level too.

Was there any modifications done on the v4.master?? is it a publishing site?

share|improve this answer
1  
You really should ask questions as a comment. –  iOnline247 Jul 26 '11 at 4:25

We did an upgrade recently (2007 to 2010) and you have to enable SharePoint Designer on General Settings for the Web Application under Central Admin, and you also have to add the developers as Farm Administrators. These are the steps I had to take to allow myself to edit pages that I was able to open prior to the upgrade.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.