Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I try to open a document library or list with Windows Explorer, I often encounter the following error:

Your client does not support opening this list with Windows Explorer

The error happens to me on some machines, but not on others. I've experience this problem on several different set-ups, with different browsers (IE6, IE8 and IE9) and different operating systems (Windows Server 2008, Windows 7). However many of my colleagues, my clients and even sometimes I have been able to successfully use this feature on other machines.

So my question is:

What settings do I need to enable in Windows / IE to ensure that Open with Windows Explorer is available?

and related, Can I get Open with Windows Explorer to work with IE9 64-bit

(Some notes; I'm on SharePoint 2007 with Single Sign On, not integrated authentication)

share|improve this question
add comment

7 Answers 7

up vote 2 down vote accepted

In my case, the step that was missing was to add the website to my list of trusted sites in Internet Explorer. That takes the list of pre-requisites to:

share|improve this answer
add comment

This fixed my problem....

1) From Internet Explorer select Tools -> Internet Options -> Security tab

2) Select Local internet -> Sites -> Advanced ->

3) Under Add this website to the zone: type https://*.microsoftonline.com -> Add

share|improve this answer
add comment

The way i made it work when after enabling WebClient and adding to trusted website the "explorer" feature was still not working, was very simple. The issue is in IE9 64-bit, Windows does not allow you to download it from the website but installs it automatically when you install 64-bit version. So the only thing you need to do is to go to start menu and just run IE9 32-version which is right under 64-bit version. It worked smoothly.

share|improve this answer
add comment

Make sure you map the Sharepoint server... See http://support.microsoft.com/kb/2616712

share|improve this answer
add comment

The Webclient service needs to be running on the client

share|improve this answer
    
I have the WebClient running (it's set to auto-start by default on Win 7 machines), so there must be more to it than just this.. any other thoughts? –  Dexter Jun 23 '11 at 10:19
    
According to an anonymous user edit you have to tick the box that says "keep me signed in". Haven't checked this. –  SPDoctor Mar 13 '13 at 17:30
add comment

The WebClient service as mentioned by @colin is indeed required. On newer versions of Windows Server you need to enable the 'Desktop Experience' Feature (Windows Server Feature, not SharePoint Feature)

share|improve this answer
    
Yes - I've previously had success with enabling the Desktop Experience feature on Windows Server, although I think this is probably not sufficient in and of itself (I don't have access to a Server atm, but have not always been able to connect from servers with the desktop experience enabled) - is there anything else you must enable / install / configure to get this to work? –  Dexter Jun 23 '11 at 10:20
1  
This always does the trick for me, although I am not sure about IE 64bit as use of that browser is generally not recommended anyway. –  Muhimbi Jun 23 '11 at 10:44
add comment

Sorry guys, but the story about enabling Desktop Experience feature on Windows 2008 R2 is rubbish as far as I am concerned. Read more at this blog: SharePoint WebDAV, IIS 7.5 and Windows Server 2008 R2

You actually need to remove the IIS Webdav Module so that the request gets through to SharePoint.

The prerequisites that you need the Webclient service running on your client and that the site needed to be in your trusted sites / intranet sites was something I did not test as we already had that configuration.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.