Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a delegate control that is appending to the AdditionalPageHead. This delegate control is appending a custom class of mine that inherits from Control. It runs some logic, and when appropriate, grabs a handle on the PlaceHolderMain of the current master page. Then, it appends some markup into that. The process of which I am doing can be found here, in a blog post I wrote.

I'm having some issues with the delegate control rendering out, even though it is not activated. The feature is scoped to the SPWeb (sub site).

What in the hell is going on?

Edit 1

These features used to be activated at the Site (Site Collection) level, and have since been changed to scope to the web.

Edit 2

I think there is some sort of caching going on. I have some editor controls that display following my blog post I linked to. I'm seeing double on a page right now where that feature is activated. This is weird.

Edit 3

I deleted the default snk from the project, added a new one, re-built, packaged, and deployed. Same fricking thing is happening.

Please see the accepted answer & comments for details

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Are you sure the feature isnt still activated on Site scope? That would explain why you see it twice.

Another thing to try is to force all sites to flush object cache under

_LAYOUTS/objectcachesettings.aspx
share|improve this answer
    
It isn't activated at the Site. It doesn't show up in the list. Using powershell, I didn't see the feature at the SITE level, only the WEB. –  Tim Gabrhel Jun 23 '11 at 13:07
1  
Did you deactivate it before you changed the scope to web? Have you done an IIS reset for the caching? –  MBSurf Jun 23 '11 at 14:31
2  
@MBSmurf my point exactly. You may have orphaned the feature if you didnt disable it before changing. Honestly, I havent tried changing scopes like that on deployed features (creating a new feature with a new ID is the way to go) so not sure it that matches the behaviour we are seing here.. –  Anders Rask Jun 23 '11 at 14:34
    
I think this ended up being what the problem was. Once I changed the feature scope back to SITE, everything was working properly. What I don't understand, is if there is still an orphaned feature, why can't I see/deactivate it in the features list? I didn't see it with powershell either. –  Tim Gabrhel Jun 24 '11 at 15:35
    
Orphaned features are what the name implies, they're there, but have no "owner", so don't display in the feature list. It's the same as moving a site to a new machine, without having all the needed features (features activated in the site) installed on it. –  Colin Jun 24 '11 at 17:26
add comment

I got into this situation as well, and yes the cause was - I changed scope of the feature Site>Web and didn't deactivated it. It's very easy to fix, just switch back the scope, deactivate the feature and switch it forward to a new value. I've blogged about it: http://maxim-dikhtyaruk.blogspot.com.au/2014/04/sharepoint-delegate-control-is-rendered.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.