Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am having trouble retracting solutions in SharePoint 2007.

I used both the retract solution button and the stsadm command in command line. The timer job was created in both instances, but it never gets run... it just sits in the timer job definition. The Status of the target just said "Retracting (scheduled at m/dd/yyyy MM:SS AM/PM)". I've waited for a long time and nothing happens.

Has anyone experienced this before, and does anyone have a solution to this problem?

Thanks.

share|improve this question

migrated from stackoverflow.com Jun 20 '11 at 15:37

This question came from our site for professional and enthusiast programmers.

    
@BeraCim: Do you solve this problem? I faced with the same and don't know how to solve it. I use Windows Server 2008 r2 x64. Could you you please comment if find solution. In my situation both SharePoint Administration and Timer are running. stsadm -o execadmsvcjobs returns "Operation completed successfully", but solution still retracking ( –  Kai Jan 28 '11 at 10:05
    
@Kai: my timer jobs were already up and running so all I needed was to manually execute the jobs in the queue using execadmsvcjobs. I could see the jobs getting executed in the command prompt. You might want to first check whether the jobs have been placed in the timer queue in central admin (Operations -> Timer job definitions). –  BeraCim Jan 30 '11 at 22:40

2 Answers 2

up vote 5 down vote accepted

Check if your Windows SharePoint Services Administration and Windows SharePoint Services Timer jobs are running.

Also after ensuring, run this command

stsadm -o execadmsvcjobs

share|improve this answer
    
The execadmsvcjobs made the difference. Thanks. –  BeraCim Jan 13 '11 at 4:54
  1. Make sure the OWSTIMER service is running
  2. Check the ULS logs
  3. Try SharePointOverflow :-)
share|improve this answer
    
@pst: I had a look at my log and found pages of stuff from OWSTIMER that says "Preserving template record with size..." and "The previous instance of timer job 'blah', id {}, for service {} is still running, so the current instance will be skipped.". Not sure what that means or how to solve that at all... and SharePointOverflow didn't return anything obviously useful. –  BeraCim Jan 13 '11 at 4:43
    
Hi ..did anyone solved this problem.I have got the same issue and even execadmsvcjobs command is not working for me..Is there any solution that you came across –  alienavatar May 17 '11 at 18:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.