SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had a request from a user to modify an InfoPath Form template, which I did, and it worked perfectly in my development environment. When I went to update the existing form in my test environment, the installation got stuck. So I removed the existing template, and re-installed the it.

That fixed the form, and I was able to create and edit new forms, but existing forms that used the old version of the template no longer open. When I click to open them, I get the following error message:

The following location is not accessible, because it is in a different site collection: https://testServer/FormServerTemplates/MyModifiedForm.xsn.

All of my changes are cosmetic, I just created a new view that displayed the text in an expression box rather than a text box. (due to scroll bars, the form was printing badly)

share|improve this question

When yo publish a form template to a list or content type in SharePoint (or a file share for that matter) you cannot just move the template to another location.

You say you move from dev to test, but how do you do this? have you wrapped your changes in a SharePoint solution or are you deploying from within InfoPath?

Check out this guidance for deploying InfoPath templates between environments.

share|improve this answer
Thanks for replying Anders. I actually solved my problem this morning. I found that the content database in our test environment (which is rarely used, sadly) was restored by a contractor from production. The Form's Library data in test was still referencing the Template's URL with and ssl url (https), rather than the test environment's lack of ssl (http). Once I updated the entries within the test environment to correctly not use ssl, it worked fine. – N801 Jun 20 '11 at 22:19
Ok please add as answer then, so Q is not abandoned, and mark as answer when you can – Anders Rask Jun 21 '11 at 6:07

I found that my issue was due to our testing environment was loaded from a backup of the production content database. The Info Path Form Library holding all of the generated forms had the host name updated, but not the SSL protocol updated. So the url to the form's template was


rather than the test environments


Once I corrected the link to the form template, the existing forms were working correctly.

share|improve this answer
Where can I find these settings? – Codingo Mar 25 '14 at 2:20
Sorry, been a while since I did InfoPath stuff. From what I remember it was when I was opening the file with the InfoPath editor, under one of the menu options. Sorry I can't of more help! – N801 Apr 3 '14 at 18:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.