SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my SP2010 farm, I have :

  • one domain group "AD Group"
    • the group have domain\user2 as a member
  • one site group "SP group" with the following members
    • AD group
    • domain\user1

On the home page, I put a webpart I want to display only to members of the "SP group". To achieve that, I set up a target audience to this SP group (SharePoint group kind of audience).

When the user1 displays the page, the webpart is visible (as the user1 is explicitly declared in the group). When the user2 displays the page, the webpart is not visible, even if the user2 is member of the group (implicitly from the AD group).

What can be wrong ? Is this scenario supported in theory ?

[Edit] Don't know if it can help, but in the documentation, I can read :

Note: Although SharePoint groups can be used with Web Parts to target content, they cannot be used to define audiences.

I understand in this sentence that it should work... but the sentence is confusing a bit.

share|improve this question
up vote 1 down vote accepted

Audience targeting will not work with an Active Directory group directly inside of a SharePoint group.

If you want to use an active directory group with audience targeting, you'll need to set up an audience in your SSP.

share|improve this answer
does it applies to v2010 ? – Steve B Jun 20 '11 at 18:46
For 2010, it looks like the steps are slightly different. – Kit Menke Jun 20 '11 at 19:46

I do this for many webparts in SP2010. I have SP groups that contain AD Security Groups. I use the Target Audience field within the webpart options to define which SP group should see the webpart. Seems to work fine for me.

I do not have any Audiences defined in Central Admin.

Not sure if this matters, but... in your example User 1 is ensured. Is User 2 ensured? If not try ensuring the user (explicitly add them to a completely separate group). Can't say that this will work, but most of my users are ensured.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.