Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

i have a UAT machine where i have created a web application and site on port 90 which is different. In Alternate Access Mapping I have mapped 10.21.21.188:90 (main site) as default and 10.21.21.188:9000 (central admin) ...when i access the site from browser by typing the ip address with port I have no problems at all...but later I did the following.

  1. Created a DNS www.mydomain.com and point to 10.21.21.188
  2. In IIS 7.0 I went to the site and went into EDIT BINDINGS and added another binding with http://www.mydomain.com on port 90
  3. IISReset -noforce

when I tried accessing by typing http://mydomain.com the site came...but when I try to do visual upgrade or upload item in list it says FILE NOT FOUND...but when I undo all the above changes in point 1.2.3 and change alternate access mapping based on IP everything works as i want.

Whats the problem.

share|improve this question
add comment

2 Answers

never modify things in IIS, as you will introduce differences between the actual config, and the SharePoint known config (in the config DB). Allways use the central administration or the PowerShell console to update such things.

In your case, did you tried to set up the host header in admin config of SharePoint ?

[edit] If you mess your farm, I suggest you to start from scratch. However, I imagine it can't be realistic for you to reinstall the farm, is it ?

You should remove any manual customization from IIS, and then extend your web app with the correct settings

Another approach you can try, is to create a new webapplication with the correct host header, then migrate the site collection from the first application to the second. Then you can tune AAM.

share|improve this answer
    
yep...now guess what? i've messed my AAM..and cant get my central administration page also..and figuring out where to change AAM without using central admin :) –  user239684 Jun 20 '11 at 7:11
    
ran CMDLET using powershell and all well but still my posted question is same..any help as i am back on previous position? –  user239684 Jun 20 '11 at 7:31
add comment

Instead of editing the bindings in IIS I would suggest extending your web application, and let SharePoint take care of it.

Do you need to access the site using the IP address at all? If not then I would create the DNS entry first and then use the domain name when setting up the web application (or extending it to another zone). If you don't need to use the IP address but it is already created you can delete that IIS site in the web application configuration page in Central Administration.

Alternate Access Mappings are intended to support incoming requests from proxies and load balancers that change the URL. They are not there to change the URL bindings.

share|improve this answer
    
SPDoctor thanks u've cleared my understanding about AAM's :) can u knidly guide where to go? like -> Central Admin ->?? to delete IIS site and all –  user239684 Jun 20 '11 at 9:00
    
Yes, CA -> Application management -> Manage web applications. Select the web app. The extend and delete buttons are on the ribbon. Note that the delete button gives you two options - delete the web app or delete the IIS site. From memory you can actually delete IIS sites so you have no site at all, just the web app and content db. Then you can extend - useful if you got the url wrong first time round. But be careful what you delete ;-) –  SPDoctor Jun 20 '11 at 16:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.