Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have two websites 1)Internal and 2)External. The external website is extended from the internal website. I can see the search results when I search on the internal site, but I am getting 0 results on the external site.

Are there any configuration settings needed to see the search results for my external site?

share|improve this question
    
Is there any other information you can add that would help us answer your question? –  Kit Menke Jun 17 '11 at 21:06

3 Answers 3

Do the content sources in your search service match the URL in your alternate access mappings? If not, set up a content source that matches the alternate access mapping and do a full crawl. While you're in the search service, you may want to check to see if it is reporting any errors.

Also check the event viewer on the server and the ULS logs (in the "14 hive") to see if anything stands out (e.g. permission issues).

This TechNet article explains how to set the content sources.

share|improve this answer
    
Hi Rob, Both AAM URL's and Content Source URL's are same. And it is not returning any errors. –  Share Jun 20 '11 at 2:11
    
Does anything in this thread hit home? social.technet.microsoft.com/Forums/en-NZ/sharepoint2010setup/… Maybe the latest Cumulative Update would work for you? –  Rob Wilson Jun 20 '11 at 2:34

On your Internal server, you should see some error messages in the Crawl log for that content source. You may want to setup a separate content source for the External server on the Internal Search Administration site. Then you can fire off Full Crawls and review the Crawl logs quickly.

You will need to grant Read access on the External site (http://your_site/_admin/policy.aspx) to the Search service account you are using on your internal site. Does the AAM/Content Source address you are using have NTLM enabled? If you are calling a Zone on the External server that is dedicated to Anonymous you may need to use a different address that does have NTLM.

share|improve this answer

Had the same issue and it drove me nuts.. finally got it working.

Trick is to create a new search center page and also modify your search scopes :)

Blogged it today here http://wellytonian.com/2012/04/search-setup-for-anonymous-site-on-sharepoint-2010/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.