Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I noticed that "Choice List Settings" is missing when adding a custom property to user profile (thru CA).

  1. Did it get replaced with Term Set?
  2. If yes, will the multi-value custom field play well with Term Set?
  3. How do I set Term Set (if I need to go this route) for Customers and Region (region has some heirchy going on. Global>continent>country)
share|improve this question
    
I would really like some input on this. I have a meeting in few hours and need to come up with a solution and timeline. Please suggest. –  Robert G Jun 17 '11 at 16:16
add comment

3 Answers

up vote 0 down vote accepted

To answer specifically on your answers, and elaborate on Doc's answer:

  1. Choice lists has been replaced by Term Sets
  2. Term sets can be selected with moth single and multiple string fields depending on what you want
  3. When you set up your meta data service application, creating hierarchies are very easy. They can consist of hierarchies of up to 7 levels, they can be localized with labels for different languages, and they can be open (folksonomies) or closed (taxonomies). Users will be presented with a picker control where they an both type in and get auto completion, or open hierarchy in a tree view control
share|improve this answer
    
All this is good now. I was able to set everything up as planned. Search is working as well. However, 2 of the custom fiels are multi value (and associated with term-store). Howerver, in the search option these 2 fields are showing up a simple text box input instead of end user to pick it from the term set's picker list. –  Robert G Jun 20 '11 at 18:48
    
If our answers have helped you, vote up or mark as answer. If you have new questions, create a new question. –  Anders Rask Jun 20 '11 at 18:56
add comment

The user profile service is dependent on the Managed Metadata service in SharePoint 2010. A lot of profile properties will show as disabled if your Managed Metadata service is not set up correctly.

There is a blog post on setting up a custom property using term sets here.

share|improve this answer
add comment

I am on a last step where i am unable to display the terms sets in the "Search Options" properties.

<Properties>
<Property Name="CustomerAccount" ManagedName="CustomerAccount" ProfileURI="urn:schemas-microsoft-com:sharepoint:portal:profile:CustomerAccount"/>
</Properties>
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.