Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I set up a team site which I manage access to it using an AD group. Whenever a new hire comes to the company, his user name is added to the AD group. The first time a added the group to the members of site, all users in the group got access. However, the new hires are not given access. The user list does not get refreshed by SP.

It's worth it mentioning that adding the user manually gives him access to the site.

Am I missing a config step in here?

My IT support team tested with another AD group and site. It worked. It looks like the issue only happens in this team site.

share|improve this question
add comment

2 Answers

Check the AD catalog Sharepoint authenticates against. If it goes to a backup Domain controller, the AD catalog there might not be up to date.

share|improve this answer
add comment

Are the user profiles being imported into Sharepoint by the Shared Service Provider? Check to make sure both a full import and incrimental imports are configured.

Also check that the content database that the site collection resides in is not marked as offline.

share|improve this answer
    
user profiles does not affect authentication of a site –  Anders Rask Jun 11 '11 at 16:24
    
But it does consume ad Groups in the import process –  PirateEric Jun 12 '11 at 11:36
    
I've seen first hand strange issues with users logging into sites when content databases are marked as offline and not ready and user profile imports not being configured. I brought it on myself in our migration from 2003 to 2007. So while it isn't directly tied to authentication, it can be a possible issue. –  PirateEric Jun 12 '11 at 12:19
    
Anders, I'd apprecite it if you reversed your down vote, group memberships are enumerated through the profile import. See this thread, sharepoint.stackexchange.com/questions/14649/…, and this article, technet.microsoft.com/en-us/library/gg188041.aspx#groups. –  PirateEric Jun 15 '11 at 20:47
    
You really cant compare SP2010 user profile synchronization using FIM with MOSS (also the article states that groups are only used for Audiences, not authentication). I cannot see the connection between user profiles and authentication, sorry :-S –  Anders Rask Jun 15 '11 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.