Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to create two web parts (that are not in the same project) that can connect.

So far I have created

  1. The interface that will be used for communication. It is in it's own Class Library project.

  2. The Provider web part which references the interface class

  3. The consumer web part which references the interface class also.

I followed the instructions from this tutorial, and modified them slightly to accommodate that the web parts were in different projects.

My problem is that when I add both web parts to the page, neither have the "Connections" option in their menu (the one that has "Edit webpart" in it).

What do I need to add to the Web Part in order to make this option appear? I'm not sure if it is related but I already have "Allow Connections" checked in the web part settings.

share|improve this question
    
Hi Abe, It's a little bit difficult to analyze what is wrong here. Did you try building the example in the tutorial without making changes? Is the Connections option available then? –  Anita Boerboom Jun 10 '11 at 6:47
    
Yes, I have since gone back and done the tutorial described in the link and it is still not showing the "Connections" menu item. –  Abe Miessler Jun 10 '11 at 16:33

1 Answer 1

up vote 1 down vote accepted

I made a small example on the provider consumer visual webparts. You can find it here: http://www.itidea.nl/index.php/simple-provider-consumer-visual-webparts/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.