SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'd like to modify the RichHtmlField to disable the color controls in SharePoint 2010. I tried adding this to my master page:

<PublishingWebControls:RichHtmlField FieldName="PublishingPageContent" allowFontColorMenus="false" runat="server" />

but it doesn't seem to have any affect on the editing pages in SharePoint. Any ideas how to enable/disable controls in the rich HTML editor?

share|improve this question
There is an option to disable buttons in Editor Toolbar. If you need technical help, please contact me on Thanks, Anand – user630119 Jul 12 '11 at 9:55

You added a control to the masterpage, which does nothing to other RichHtmlFields, it's just it's own control. Are you using the SP2010 wiki style apges or publishing?

share|improve this answer
Ah, I see. So how do I modify the control on the page? I'm using the publishing pages. – stomcavage Jun 13 '11 at 13:23

Instead of adding a new control to the masterpage you need to open up your Page Layout and modify the existing RichHtmlField controls.

They are under /_catalogs/masterpage/page_layout_file_name

share|improve this answer

I did something like this for a customer. You can read a post in this url:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.