Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a Web application(http://extranet:80 - Default Zone) running only on claims authentication and with a Trusted Identity provider and no NTLM, obviously content from this site wasn’t being crawled , so we created an extension (http://extranetsearch:81 - Custom Zone) whit NTLM to make it work, the crawl log shows that there’s content being successfully crawled from the extended site but when I do a search on any of this sites there’s no results, I´ve been checking the logs and apparently there’s no error in the crawl component nor the query processor, I ‘ve been testing the search using different user accounts, site admin and the search service account and still no results.

So I’m clueless about what could cause this kind of behavior any help will be highly appreciated.

Thanks!

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I ran into something similar recently. Lots of crawled content, but empty search results. In my case, switching the search application to store as Claims solved the problem.

$SearchApp = Get-SPServiceApplication SearchAppName

$SearchApp.setproperty(“ForceClaimACLs”, 1)

I still don't know what the exact underlying issue was, but I believe it is related to the search service or crawl account not being able to read certain attributes on AD accounts.

share|improve this answer
    
Same here. Goes for One-way domain trusts too –  Colin Jun 9 '11 at 8:50
    
Thanks this did the trick! –  Hugo Molina Jun 9 '11 at 17:41

Does it work if you search from the custom zone? My guess is that the search security trimming rejects all results when you are searching from the default zone that does not use a NTLM authentication provider. You will probably need to enable anonymous access and do a full crawl to see any results.

share|improve this answer
    
Thanks for answering!! but.. Nope, still no results even when doing a search from the custom zone, I´m going to enable anonymous on both sites and see if that works.. –  Hugo Molina Jun 8 '11 at 17:24
    
It might also help to swap the zones. Search prefers to authenticate against the default zone. –  Lars Fastrup Jun 8 '11 at 17:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.