Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.
The SharePoint site with the id {GUID} could not be found. (rsSPSiteNotFound)

The source farm reports work fine, but after the restore to a new farm, some (not all) reports get this error. Looked at many blog posts and they all seemed related to BlobCache. Not using it currently. In the web.config, I ensured that the blobcache is set false.

Reference: http://blogs.msdn.com/b/joshuag/archive/2008/05/22/filenotfoundexception-the-site-with-the-id-guid-could-not-be-found.aspx?PageIndex=2

This is on SharePoint 2010 with Reporting Services 2008 R2 in a multi-server farm

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I believe I figured this out. I had to go to the list of Data Connections that are being used by the reports, clicking on each data connection, clicking Test Connection (which rewires the connection and clears any cache related to that report) then clicking Okay. This solved my problem.

share|improve this answer
    
that's right - it solved mine too –  user5940 Dec 7 '11 at 13:08

I had the same problem in Sharepoint 2010. All my reports used shared datasets. I had to remap the datasource for each dataset and this solved my problem.

Thanks for your help.

share|improve this answer
    
Is this an answer or a "thank you" note? If it is not an answer, you have posted is in the incorrect place (this section is for answers only). If it is an answer, please add more details regarding how to remap the datasource for a dataset to make the answer more helpful –  Robert Lindgren Mar 27 at 10:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.