SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I'm setting up a crawl rule, I check 'Specify form credentials', wait a minute and then get an error message:

An unexpected error was encountered while trying to connect to The error is "The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.". The site might be unavailable or it could not be reached within the specified timeout or the proxy settings are not configured. To increase the timeout value or to configure the proxy settings, use the Proxy and timeouts page.

I don't seem to be able to set it for any site.

Logged into the server, I can get to the form. What's going on?

share|improve this question
I've noticed that http forms are fine, it's only https forms that cause an error. That is, brings up the normal login form, causes an error. – Dan Jul 1 '11 at 6:40
Hmmm, I applied SP1 and now the form credentials window comes up, I get an NTLM invitation to log in and then nothing. – Dan Jul 25 '11 at 9:08
Dan, did you ever figure out this issue? I seem to be having the same problem. http forms work fine, but https forms give me this error: "The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel." I have also disabled lookback check and added the site's certificate under "Manage Trust" in Central Admin. – SPKoder Feb 17 '12 at 20:36

The problem is that SharePoint 2010 cannot access web services running SSL unless the root certificate of the web service is trusted in SharePoint.

Try create a new trust relationship for the root certificate under CA - Security - Manage Trust - New.

share|improve this answer
It turns out that the root cert for the certificate provider for my target site is already installed, because we're using the same cert provider. No luck though, just a blank dialog box when I try to enter credentials. – Dan Sep 15 '11 at 7:39
Yes but have you added the root certificate under CA - Security - Manage Trust. It is not enough that the Root Certificate is installed on the server! The problem is that SharePoint does not trust the certificate even though it is trusted of the Windows server! Try export the root certificate from the Certificate MMC and add it to a new trust i Central Administration – Rasmus Glad Romlund Sep 15 '11 at 8:09
Welcome to SharePoint Stack Exchange! Please don't add your name as a signature to posts as this doesn't provide valuable information. Your user name is already displayed on the post. – Alex Angas Sep 18 '11 at 2:02
Yep, it's in Central Admin. – Dan Oct 4 '11 at 9:10

I had the same error. At first I didn't think Rasmus' solution worked for me, but then I realized that SharePoint requires all of the certificates in the certificate chain to be listed. In our case, I had a self-signed certificate through Go Daddy. Originally I had only added the bottom level certificate in SharePoint, and that didn't work. But after I included two Go Daddy Certification Authority certificates in Central Admin, it worked fine.

share|improve this answer

did you disable to lookback check for that server? Common mistake.

share|improve this answer
Yes, disabled long ago. – Dan Jun 7 '11 at 6:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.