Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Using SharePoint 2010, some user names in the people pickes and User Information List are shown by John Smith. Others are companyDomain\jsmith. We would like to correct this for consistency.

I have checked our active directory records, and there is no difference in how the accounts were created there. The only clue that I have is that newer employees are formatted in the latter way and older employees the former. This makes me suppose that someone made a change somewhere in SharePoint

share|improve this question
    
Is there anything askew with your user profiles? Could maybe be an error/glitch with the profile import. Check to see if they appear correctly in your user profiles service application in Central Administration. Also, are all of the users on the same domain (just want to rule out that it's two domains with a trust between them). –  webdes03 Jun 3 '11 at 21:20
    
They are all on the same domain. I am looking into the user profile service, but have never used it before. –  caschw Jun 6 '11 at 12:31
    
In the user profiles service application, pull up one of the profiles where you're seeing a username instead of a name, and look at the data. You should be able to tell if something like what Tom mentioned below is happening based on the data that SharePoint has imported from Active Directory. –  webdes03 Jun 6 '11 at 19:20
1  
User profile service was not running correctly, but some accounts were stuck in companyDomain\jsmith. the following fixes that Set-SPUser –Identity "domain\jsmith" –DisplayName "John Smith" –Web http://companyDomain.com –  caschw Jun 7 '11 at 2:19
    
@cashw I think it would be appropriate to move your comment to an answer. I would upvote it. It is a legitimate solution to this issue if you don't want to set up User Profile Synch. –  Tom Resing Aug 25 '11 at 14:35
add comment

4 Answers 4

'John Smith' should be the 'Display Name' in the AD. This will then be synchronized with user-profile service. Please make sure that your 'user profile synchronization service' is working without errors.

share|improve this answer
add comment
up vote 5 down vote accepted

User profile service was not running correctly, but some accounts were stuck in companyDomain\jsmith. the following fixes that:

Set-SPUser –Identity "domain\jsmith" –DisplayName "John Smith" –Web http://companyDomain.com
share|improve this answer
add comment

I believe I've seen this when the first name and last name properties in Active Directory were blank.

share|improve this answer
add comment

Take a look at the settings in the Person columns in the list, the display values can be configured on a column by column basis.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.