Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm watching a course on SharePoint Foundation 2010 Fundamentals.

In it a document library is created a couple of columns are added, then when New Document is selected from the ribbon, Office opens with the document information panel open and available and on save it saves to the document library.

In my document library on my local install of SharePoint 2010, when I click New Document it opens up Word without the document information panel. At the top of the document it says Protected View. This file was opened from a potentially unsafe location - Enable Editing

On clicking Enable Editing, I edit the document, but saving it saves to local machine, not to SharePoint.

If I keep this document open and go and click New Document again in the document library, then I get the expected behaviour of the document information panel and then saving to the document library.

What do I need to do to make it work as expected the first time?

I'm guessing something to do with Intranet Zone on IE but this appears to be ok.

share|improve this question

3 Answers 3

up vote 10 down vote accepted
+50

I could reproduce similar behavior locally. It may have to something with your Word Settings. When you click new and it opens in MS Word, word treats it as unsafe because perhaps it is not saved. After you click it treats it as a safe document and things works for you.

To make it work first time, you may have to go to

Word (2010) -> File Menu -> Options -> Trust Center -> Trust Center Settings -> Protected View Tab -> Uncheck "Enable Protected View for files located in potentially unsafe locations" (2nd option)

Close word and try again from SharePoint.

share|improve this answer
    
thanks that seems to have done it... I'll check after my next reboot to see its all working still before accepting. –  gotsp Jun 9 '11 at 3:59
    
Awesome. That button has always made me crazy. Didn't know you could turn it off! –  Marc D Anderson Jun 10 '11 at 12:13

From which OS are you opening the Word doc? If it is an MS Server version, the WebClient service is not installed, which is used for the Word -> SP communication. Also, in the Web app's general settings you can control how links to documents in SharePoint behave. Under the Browser File Handling section you can have sharepoint open docs in the browser (permissive), or in the client app (strict). Also under general settings, you can completely disable client integration

share|improve this answer

Add sharepoint url to trusted sites in IE settings.

share|improve this answer
    
Its already there - "This site is already in the Trusted sites zone" well http://myserver is there, the actual site is http://myserver:12345 –  gotsp Jun 5 '11 at 23:39
    
Add myserver:12345 to trusted sites. –  gandjustas Jun 6 '11 at 5:37
    
sorry for not being more specific with my last comment. When I goto trusted sites and add "myserver:12345", it gives me the error message "This site is already in the Trusted sites zone" even though the entry in the trusted sites is "myserver" without the port number –  gotsp Jun 8 '11 at 7:47
    
also if I remove the http://myserver entry from the trusted sites list and then add http://myserver:12345 to the trusted sites list then the entry in the list does NOT display the port number –  gotsp Jun 8 '11 at 7:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.