Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I created a page in SharePoint 2010 and then made some edits to the page.

Then I went into the page Version History and restored a previous version of the page.

Now I have this message that does not want to go away even 2 days after....

The current page has been customized from its template. Revert to template.

enter image description here

How do I remove this message without making changes to my MasterPage or CSS? Or am I forced to find the correct class in the CSS and change it?

share|improve this question

2 Answers 2

This is "by design" (for better or worse).

The only workaround at this stage is to use JavaScript that can target this particular message. Trying to hide it using CSS is a bad idea as it will apply to all status bar messages which are very important for end users to see.

There's an example script on Sohel's Blog:

<script type="text/javascript">
ExecuteOrDelayUntilScriptLoaded(hideWarning, "sp.js");
function hideWarning() {
    var statusbarContainer = document.getElementById('s4-statusbarcontainer');
    if (statusbarContainer != null) {    
        var messageSpan = document.getElementById('status_1_body');
        if (messageSpan != null) {
            if (messageSpan.innerHTML.indexOf('The current page has been customized from its template.') == -1)
                statusbarContainer.style.display = 'inline';
        }
    }
}
</script>

There's also a post worth reading about this on TechNet forums called How to hide Revert to Template Status on the SPD Customized Pages. Particularly the response from Dalibor MSFT shows options for dealing with this.

share|improve this answer
    
I've contacted Sohel to check that he's OK with me reproducing his script here. –  Alex Angas Jun 22 '11 at 2:56
    
Where exactly must this script be places in the page? –  Etienne Jul 28 '11 at 6:35
    
It doesn't really matter because the call to ExecuteOrDelayUntilScriptLoaded ensures that it won't run until the core SharePoint JavaScript files are loaded. You could try a delegate control or the master page. See what you can find on the web and if you have trouble please feel free to ask a new question here. –  Alex Angas Jul 28 '11 at 7:33

The best (and easiest) way that I've found to remove that notice was a workaround posted on this Consulting blog.

Using SPD, you are basically going to export a copy of the site to your local machine, re-upload it, and behold: the blue info icon is gone (which denotes that the site has deviated from the template). You can then delete the problematic page, and then rename the copy to take place of the old file.

I have also personally confirmed that this works. I modified a Home.aspx site which then produced the notification banner, and this solution did the trick. Best of all is that there's absolutely no coding (which can then produce additional problems if you don't know what you're doing. Or if SharePoint doesn't like what you're doing :D).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.