Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to connect from BCS directly to Oracle, but there is an error:

Keyword not supported: 'connect timeout'.

I think that the connection string formed for Oracle is in an incorrect format for the method:

protected virtual string CreateConnectionString(INamedPropertyDictionary lobSystemInstanceProperties){} 

Type: Microsoft.SharePoint.BusinessData.SystemSpecific.Db.DbConnectionManager

Assembly: Microsoft.SharePoint, Version=14.0.0.0.

Has anyone encountered a similar problem? Are there any solutions?

share|improve this question
    
how did you setup your BCS definition? –  Jaap Vossers Feb 3 '10 at 13:34
    
<Property Name="AuthenticationMode" Type="System.String">RdbCredentials</Property> <Property Name="DatabaseAccessProvider" Type="System.String">Oracle</Property> <Property Name="RdbConnection Data Source" Type="System.String">oracleds</Property> <Property Name="SsoApplicationId" Type="System.String">OracleDb</Property> and thats all about connection, I don't specify "connect timeout" manually –  Vitaly Baum Feb 3 '10 at 20:20
    
Did you successfully setup a SSO application called SsoApplicationId? –  Jaap Vossers Feb 4 '10 at 11:16
    
Yes, of course, but the problem isn't in the SSS –  Vitaly Baum Feb 4 '10 at 11:43
add comment

1 Answer 1

Unlike other .NET Framework data providers (SQL Server, OLE DB, and ODBC), System.Data.OracleClient's OracleConnection does not support Connection Timeout property. If you remove it from your connection string, it should work.

share|improve this answer
    
Connection string generates at runtime into method above and this parameter hardcoded into. I dont specify "connect timeout" own. –  Vitaly Baum Feb 3 '10 at 20:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.