Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I don't know whether anyone is familiar with DevExpress controls, but I am trying to implement their ASPxScheduler within SharePoint.

What I have done so far is:

  • Register the required assemblies in the GAC on the server
  • Added the assemblies in the web.config
  • Added HttpHandlerModule to web.config
  • Added the assemblies as safe controls
  • Registered the assemblies on the aspx page

This seems to be working so far, but the ASPxScheduler requires other ascx controls, and their code behind files, to be added to the site. I have added these at thge correct location (root of the site) and it seems to be picking them up. But as they are not built I get the following error:

Parser Error Message: Could not load type 'HorizontalAppointmentTemplate'.

Line 1:  <%@ Control Language="C#" Inherits="HorizontalAppointmentTemplate" Codebehind="HorizontalAppointmentTemplate.ascx.cs" %>
Line 2:  <%@ Register Assembly="DevExpress.Web.ASPxScheduler.v10.2, Version=10.2.5.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" Namespace="DevExpress.Web.ASPxScheduler" TagPrefix="dxwschs" %>
Line 3:  <%@ Register Assembly="DevExpress.Web.ASPxEditors.v10.2, Version=10.2.5.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" Namespace="DevExpress.Web.ASPxEditors" TagPrefix="dxe" %>

I have read into a few things and some say that I need to build the site locally and copy the dll's over but SharePoint Designer doesn't have an option to build and Visual Studio won't open SharePoint sites.

Any ideas?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I think, the problem is on line 1. There you specify an Inherits attribute together with the Codebehind attribute. You probably can't specify them togheter as specified here: http://msdn.microsoft.com/en-us/library/d19c0t4b(v=VS.90).aspx

Also, if you specify the Inherits attribute, you have to specify the full qualified name of your type in line 1:

<%@ Control Language="C#" Inherits="HorizontalAppointmentTemplate, <AssemblyName>, <Version>, <Culture>, <PublicKeyToken>" Codebehind="HorizontalAppointmentTemplate.ascx.cs" %>
share|improve this answer
    
Hmm, yeah I saw that, it works in my local machine, but it doesn't have .Net 3.5. However, how do I get the assembly info when I can't build the files? –  anothershrubery May 31 '11 at 13:07
    
Ok, your answer helped me get this working. I removed all the Inherits from the acsx files and put in <PageParserPath VirtualPath="/DevExpress/*" CompilationMode="Always" AllowServerSideScript="true" IncludeSubFolders="true"/> into the web.config PageParserPaths section. It now works. thanks for your help. Now need to work out how to fix the styling! –  anothershrubery May 31 '11 at 13:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.