Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

On my list the datasheet button is greyed out. How do I go about enabling it?

share|improve this question

7 Answers 7

Just on the off chance: You are using Internet Explorer, right?

If not, I'm afraid this is an IE-specific function; as I discovered when trying to pry it open with Chrome's dev tools.

share|improve this answer

Do you have the Microsoft Office client software (32-bit version) installed on your computer? This is necessary to support this function. You may also need to enable ActiveX controls if this is disabled in your browser.

share|improve this answer
    
I believe I am running office 64 bit. That could be my problem. Will test on a 32 bit machine. –  Ricky May 24 '11 at 14:47
    
Yes, you need the 32-bit version of Office. It does not need to be on a 32-bit machine, you can install 32-bit Office on either. Microsoft recommend using the 32-bit version in most cases. –  SPDoctor May 25 '11 at 7:44

It could also be turned off for the list. Check the List Settings > Advanced Settings, 'Datasheet' section.

share|improve this answer

As SPDoctor stated - it sounds like an issue with 64 bit install of Office. You cannot view a list in Datasheet view after you install the 64-bit version of Office 2010

Try installing the 2007 Office System Driver: Data Connectivity Components

share|improve this answer
    
this is 25 MB installer and resolved my issue in IE9 and after updating to IE10 . actual name in add remove is "Microsoft office 2007 access database engine" –  imanabidi Oct 27 '13 at 10:11

I have found that the 64-bit issue runs a little deeper. If your Office is 32-bit and IE is 64-bit, it seems to do the same thing. Once both are 32-bit, the datasheet icon becomes active.

share|improve this answer

It's IE 64-bit! Kills Flash & other things too. It shouldn't have been released in its current state, and I only use the 32-bit version in Windows 7.

share|improve this answer
    
Do you have any online reference of your answer? –  Benny Skogberg MCSA Jun 25 '13 at 19:08

I had similar issue .Please try adding the site to Compatibility View in IE , this might fix your issue.

share|improve this answer
    
Could you add additional details regarding how to do this? This would improve your answer's quality quite a bit. –  Robert Kaucher Mar 28 at 19:45

protected by PirateEric Mar 28 at 17:18

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.