Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have an Infopath 2007 form which I have been struggling with. Now when I close the form (from a Rule on a button), the form does not navigate back to the Source URL but instead gives a browser screen with the text "The form has been closed."

This indicates an error condition - ?Right? But how do I find it? All the promoted fields are accurately recorded on the list, I believe, so how do I go about resolving this error condition?

EDIT:

  • The Source parameter URL is correct.
  • No, even from the default forms library UI it does not close correctly.
  • I thought it might have to do with spaces in the forms library name, so I renamed it, (including the data connection). The form submits accurately, but the &Source= parameter is still ignored.
  • I have access to the ULS Logs, but I'm not sure how to interpret them. There aren't any severe errors ..
share|improve this question
    
Can you verify that the Source parameter is correct by manually putting it into the address bar and navigating there? Also, is it in the same site collection? –  Laurie May 20 '11 at 21:04
    
I've updated my question based on your additional information. Also I merged your users so you will now be able to use both of your login IDs to participate in the site. –  Alex Angas May 23 '11 at 20:33
add comment

1 Answer

As @Laurie has suggested, this may be a problem with the Source parameter in the query string used to open the form. Does the form close correctly when using the default forms library UI to open it?

If an error is occurring, the place to look is in the SharePoint ULS logs on the server. This is true for any error that occurs in SharePoint that lacks the detail you're looking for. There's a list of tools to assist here.

(If you don't have access to the server, ask your systems administrator to copy the log files for you that correspond to the time the error occurred.) For SharePoint 2007 you'll find them at:

C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\Logs

You are then looking for something to show in the logs at almost the exact time the error occurs on the screen. It will have a category of something like "InfoPath" or "Forms Server". If you are able to find that and are unsure of how to interpret it, edit your question and include the relevant line(s) so we can try to help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.