Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am getting the following error in my error logs:

Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (e2b8e1df-b956-4ada-bda4-986b09c41db9).

Reason: The device is not ready.  

Technical Support Details:
System.IO.FileNotFoundException: The device is not ready.  
   at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
   at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

How would I go about trying to work out what is wrong?

share|improve this question

2 Answers 2

  1. Stop the Windows SharePoint Services Timer service (Found in Windows Services)
  2. Navigate to the cache folder In Windows Server 2008, the configuration cache is in the following location: Drive:\ProgramData\Microsoft\SharePoint\Config In Windows Server 2003, the configuration cache is in the following location: Drive:\Documents and Settings\All Users\Application Data\Microsoft\SharePoint\Config Locate the folder that has the file "Cache.ini" (Note: The Application Data folder may be hidden. To view the hidden folder, change the folder options as required)
  3. Back up the Cache.ini file.
  4. Delete all the XML configuration files in the GUID folder. Do this so that you can verify that the GUID folder is replaced by new XML configuration files when the cache is rebuilt.
  5. Note When you empty the configuration cache in the GUID folder, make sure that you do not delete the GUID folder and the Cache.ini file that is located in the GUID folder.
  6. Double-click the Cache.ini file.
  7. On the Edit menu, click Select All. On the Edit menu, click Delete. Type 1, and then click Save on the File menu. On the File menu, click Exit.
  8. Start the Windows SharePoint Services Timer service
  9. Note The file system cache is re-created after you perform this procedure. Make sure that you perform this procedure on all servers in the server farm.
    1. Make sure that the Cache.ini file in the GUID folder now contains its previous value. For example, make sure that the value of the Cache.ini file is not 1.

For more informatio refer to this link

share|improve this answer

I ran into the same error while renaming the Search databases on a SharePoint 2013 server. I found that looking further back in the Windows Application logs explained the problem with the Search Service.

In my case I found several Warnings and Errors that came from 'SharePoint Server Search'. The errors mentioned access and permission issues with the Search database. Somehow while renaming my Search databases some permissions were lost, so I resolved my problem by comparing permissions on backup and copying the proper permissions to the live database.

share|improve this answer
    
Me too, the SPSearchDBAdmin database role was missing permissions on all stored procedures, functions, and user defined types. I had copy the permissions from a working datbase, drop the login and recreate it. –  Lou Aug 27 at 22:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.