Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm currently tasked with developing a branding solution for SharePoint Foundation sites. I've created a WSP file which can be deployed through my local machine through Visual Studios, but when I upload the solution into the Solution Gallery in site settings, I can't activate the solution. The solution was created as a sandboxed solution according to this article.

When I choose to activate from the RibbonMenu or the drop down for the solution, the resulting modal dialog has an activation button which is disabled. I'm logged in as the System Account, so I believe I have full permissions over the site collection.

What do I need to do in order to activate solutions from this gallery page?

share|improve this question

migrated from superuser.com May 19 '11 at 4:57

This question came from our site for computer enthusiasts and power users.

1 Answer 1

up vote 10 down vote accepted

Can you check that ou have enabled and configured the user code service on your farm and started it?

Look for user code service in service applications and create one if it is not there.

Then go to

Central Administration > System Settings > Manage Services on Server > check that “Microsoft SharePoint Foundation Sandboxed Code Service” service is running

share|improve this answer
    
This was the precise issue! Thanks a lot! –  jackofallcode May 19 '11 at 13:01
1  
Tiny correction: "Look for user code service in service applications" should be "Look for user code service in services". Small distinction but possibly confusing for newbies. There's no user code service application to create. The Central Administration navigation progression is right though. –  Yohan P Aug 13 '12 at 3:25
    
which server should it be enabled on? The WFE or the App Server? (For what it's worth, I enabled it everywhere and it seemed to work) –  Hutch Jul 11 at 22:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.