Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've set

<system.web>
  <customErrors mode="Off" />
</system.web>

in my web.config file, but i'm still getting 'unknown error' instead of the stacktrace on my pages. How can I view the stacktrace?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

If you're getting this error on sharepoint/wss specific pages, you also have to add following fragment to your web.config to view the stacktrace:

<SharePoint>
    <SafeMode MaxControls="200" CallStack="true" DirectFileDependencies="10" TotalFileDependencies="50" AllowPageLevelTrace="false">
      <PageParserPaths>
      </PageParserPaths>
    </SafeMode>
</Sharepoint>

You can define a specific path in the PageParserPaths element, but this is optional. Don't forget to turn off the custom errors after you found the problem (certainly for a public facing site).

share|improve this answer
1  
I think it is worth noting that you may already have CallStack="false" in your web.config, so you may just need to change it to true. –  Kit Menke May 16 '11 at 14:36
add comment

The full range of things to do is listed on this page:

http://blogs.prexens.com/Lists/Posts/Post.aspx?List=7a299699-f8da-4559-920c-bda481608691&ID=8

You need to also set CallStack to true in the SafeMode node to see the CallStack you require.

share|improve this answer
add comment

Try setting <customErrors mode="Off" /> in the following web.config file in addition to your webapp web.config file.

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\ADMIN\web.config
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.