SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I get following error when I click on "Add Document" on a infopath library.

This feature requires Microsoft Internet Explorer 7 or later and a Microsoft Sharepoint Foundation-compatible XML editor such as Microsoft InfoPath.

I tried settings > and open it from server (open in browser) and still get the error.

share|improve this question

Please verify which version of SharePoint you are running. The user can only open an InfoPath form in the browser if the server is running Form Services in SP2010 Enterprise or Forms Server (an additional server product). If you are running SharePoint Foundation or Standard SP2010 the user can only open the form in the InfoPath client. And from the error message, it sounds like you do not have InfoPath installed on the client.

share|improve this answer
I will look into your suggestion. thanks Laurie – Roxanne May 16 '11 at 3:58
Yes, Laurie's point is valid, I had assumed Infopath Form services were running (and forgot to include that in my assumptions list :-)...) – sumitkm May 19 '11 at 19:39

I am assuming you are trying this on IE7+ and you have Microsoft Infopath installed on your computer

Try repairing Office installation by

  • Close all instance of IE
  • Close all Office Products
  • Go to 'Program Files'->'Microsoft Office'->'Microsoft Office Tools'->'Microsoft Office Diagnostics'
  • Let the diagnostics complete and reboot if it asks you to.
  • Try adding Infopath Form now.
share|improve this answer
I will certainly go through these and see where problem lies. – Roxanne May 16 '11 at 3:59
I dont see program files > mo > mot... – Roxanne May 19 '11 at 18:38
Hmm... could be it wasn't installed by default... Try the option suggested here... (basically launch diagnostics from inside Office Apps)… – sumitkm May 19 '11 at 18:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.