Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am getting "the file exist" error while deploying wsp file on my web application in moss 2007.

error is: servername : "The File exists"

please help me to find the cause and solution for this error. thank you.

share|improve this question
    
Please, check your sharepoint logs and provide more detailed error information. –  Andrey Markeev May 12 '11 at 12:40

2 Answers 2

up vote 2 down vote accepted

This is a common error if the WSP you are deploying is attempting to deploy a DLL that is also deployed in another WSP. If that is the case, make one WSP be responsible for the DLL and remove it from the deployment instructions in the other WSP.

share|improve this answer
    
thanks for reply.actually we are using third party wsp(Bamboo) so we dont have source code to this modification. –  ARD May 13 '11 at 13:12

If you are 're-deploying' an already deployed solution you should try to use the stsadmin upgradesolution, refer to the following for syntax:

http://msdn.microsoft.com/en-us/library/cc262014(v=office.12).aspx
http://technet.microsoft.com/en-us/library/cc262014(office.12).aspx

Beyond this as omlin said above we need more info.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.