Sign up ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

SharePoint Designer was giving me a popup to tell me I could edit the page in advanced mode. This has stopped happening and now I just get a page with yellow background.

How can I edit the page layout in advanced mode?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Have a look in the ribbon and click Advanced Mode.

More info in this article -

In answer to @Havoc

If advanced mode not available it may be due to a setting in Central Admin From this link

Central Administration

Use the SharePoint Designer Settings page in Central Administration to manage SharePoint Designer at the web application level, which includes all site collections in the web application. These settings apply to site collection administrators and all users of the web application.

Enable Detaching Pages from the Site Definition

Enables or disables the ability to detach pages from the site definition. If unchecked, SharePoint Designer only allows you to edit pages in normal mode. The Edit File in Advanced Mode is disabled. Note This setting does not apply to pages that have already been detached as well as new blank ASPX or HTML pages created by the user.

share|improve this answer
What happens if "Advanced Mode" is grayed out? – Havoc Aug 13 at 0:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.