Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm facing Cannot connect to configuration database error while trying to access my site. This happened after I installed Active Directory and made my sharepoint server the domain controller, which I know was a big mistake. I then demoted domain controller and uninstalled AD, but the problem is all configured accounts are gone and groups such as WSS_ADMIN_WPG, WSS_RESTRICTED_WPG and WSS_WPG too. I created these groups manually and managed to start Sharepoint Services Administration service with newly created account so Central Administration is working, but I was unable to fix access to my portal site. Any help in solving this problem would be appreciated. Thanks in advance!

share|improve this question
add comment

1 Answer 1

Try to launch configuration wizard.
If it ask you to connect to an existing farm, connect to the existing configuration database.
If not, just going though the wizard may recreate all needed groups and permissions.

Considering the bad state of the farm, backuping the content databases and recreating the farm from scratch may be a good idea.

share|improve this answer
    
Thanks for your reply! I tried to run this wizard but it failed with strange error on step 3. After getting that error I created WSS_ADMIN_WPG, WSS_RESTRICTED_WPG and WSS_WPG groups and added account for central administration service to them and configuration process went a bit further, but still failed on step 3. I consider the second option too, though I"m worried that different other problems may occur. –  user3351 May 11 '11 at 9:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.