Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Our WSS3 document libraries no longer prompt to check out. I've confirmed check out is required for editing, and I've tried a new library. We're getting the same results. I also check the authentication provider and ensured client integration is enabled. This has been working great for quite some time. Users are using Office 2003. Could there have been a Windows Server update which disabled this for the old Office version?

When attempting to check out the file within SharePoint, using it's resident checkout functionality I get an error

The file "MyFile.xls" is not checked out.

share|improve this question
    
Do you mean that they do not get a prompt in Office 2003 anymore to save / checkout as a minor or major version or that no versions are added in SharePoint itself? –  Roel Hans Bethlehem May 10 '11 at 17:29
    
Do you happen to use Citrix? I have seen one case with a client that migrated to Citrix. After that the prompting for check in / check out disappeared. –  Roel Hans Bethlehem May 10 '11 at 19:26
    
Correct, Office doesn't prompt to check out, and there isn't an option to check it out to edit. If they edit it, they have to upload it manually. –  David Lozzi May 11 '11 at 2:10
    
Nope, no Citrix –  David Lozzi May 11 '11 at 2:11
    
Did some more research on the error and discovered there's a hotfix available, then checked the version of the server and it doesn't have a SP installed yet, so we'll try that first. –  David Lozzi May 12 '11 at 13:19

2 Answers 2

This could be a client issues. Try the following if the SP does not work. Run the Microsoft Office Diagnostic Tool, which is part you the Office installation on a client. This will look for and correct any errors in your Office installation. When the diagnostic tool is finished try to check out and edit a document. The David Klein's blog entry for additional information. Read the comment too.

share|improve this answer
up vote 2 down vote accepted

Installing the latest service pack resolved the issue!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.